1
$\begingroup$

I can't find the solution to this one; I don't know the correct name of the problem. The shading is different on parallel faces facing the same direction.

Shading different on parallel faces

I've tried: - Recalculating Normals - Removing doubles - Tried smooth and flat shading - Deleting and remaking faces - Adding Edge Split modifier

Any ideas? Thanks

Edit: Link to .blend:

$\endgroup$
  • $\begingroup$ Have you tried appling rotation and scale of the objects? Go to object mode, select all, ctrl + a and rotastion and scale. $\endgroup$ – Mark Kirby Sep 25 '17 at 9:26
  • $\begingroup$ it could be materials/texturing gone wrong... but we know nothing about that. If you can, upload a small sample here blend-exchange.giantcowfilms.com then add the provided link to your question text $\endgroup$ – m.ardito Sep 25 '17 at 9:26
  • $\begingroup$ @MarkKirby Applied rotation & scale, no change $\endgroup$ – Darren Heffernan Sep 25 '17 at 9:31
  • $\begingroup$ @m.ardito I will upload the file now, thanks for your time $\endgroup$ – Darren Heffernan Sep 25 '17 at 9:31
5
$\begingroup$

You have autosmooth enabled, you just need to disable it:

enter image description here

Since your objects have all triangular faces, what you see is the result of auto smooth shading which enhances those triangular shapes.

edit: to other readers benefit, I'll add that as (again) @Mr Zak pointed out, the real reason for this behavior should be "custom split normals" created by the external application from which it was imported this file in Blender.

below an image showing how to remove those custom split normal data (I couldn't find it before), and the effect on 3d viewport shading. After clearing that custom data, the "autosmooth" limit angle data is enabled again, although it is not needed at all in this case.

enter image description here

$\endgroup$
  • $\begingroup$ Thank you! Haven't seen/heard of that option before. $\endgroup$ – Darren Heffernan Sep 25 '17 at 9:50
  • $\begingroup$ It's not there by default. iirc, someone must have enabled it (but on such square shape there's nothing to be smoothed, honestly: it's usually more used on curved surfaces). There are "box sides" which still have apparently two materials on different triangles, it is sufficient to assign those triangles to the right material... $\endgroup$ – m.ardito Sep 25 '17 at 9:57
  • $\begingroup$ I've been working on it and it has been back and forth between different computers, so it was probably an accidental enable on my part. Really appreciate the help. Thanks m.ardito $\endgroup$ – Darren Heffernan Sep 25 '17 at 10:20
  • 2
    $\begingroup$ That's mostly because of custom split normals (probably exported from another app). AutoSmooth would fix those grey normals by default, but coincidentally turning it on enables custom split normals as well. See blender.stackexchange.com/questions/76513/… $\endgroup$ – Mr Zak Sep 25 '17 at 10:37
  • $\begingroup$ as @MrZak says above, under the "autosmooth" you see that the limit angle selection is greyed, and hovering description says that's "unused" if there are custom split normals, but I couldn't find a way to "remove" or "revert" them in your file... I wonder if that "autosmooth" could be there because blender tried to "adapt", with its own tools, a mesh setup that you imported from elsewhere... $\endgroup$ – m.ardito Sep 25 '17 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.