0
$\begingroup$

I have two bones with parent/child relation ship.

Child bone does not inherit rotation from Parent because I turned it off (unchecked the Inherit Rotation) as I don't want the child to rotate with parent.

This works perfectly in Blender. But when I export to FBX (with Baked Animation) to use in another software, the rotation is inherited.

How do I export the animation with inherit rotation turned off?

I've tried turning it on and adding a constraint to limit rotation but it has the same problem.

$\endgroup$

2 Answers 2

1
$\begingroup$

Probably the problems comes from an "inherit rotation" behaviour of the destination rig. If you baked all animation infos (loc and rot) you can break the parent-child relationship of the destination rig, and everything should be OK.

$\endgroup$
1
$\begingroup$

Option 1: Change the rig. Assuming Child's head lays at the position of Parent's tail, and the Child isn't inheriting any scaling, give Child a Copy Location constraint targeting Parent, with head/tail set to 1.0, then unparent Child. Rebake the animation with Visual Keying and Clear Constraints.

Option 2: Recalculate your rotation by using an interim bone. Duplicate Child, enable inherit rotation on the duplicate, then give the duplicate a Copy Transforms constraint targeting the original Child. Bake your animation (with Visual Keying and Clear Constraints.) Copy/paste the duplicate's keyframes onto the original Child bone. Enable inherit rotation on the original Child, then delete your duplicate bone.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .