1
$\begingroup$

I've been using sculpt mode and messed up my horse model's head.

I had been improving the eyes and accidently used one brush wrong. I cannot undo it anymore now. Luckily, I have the model before the change found in an autosave file.

Now I want to do one of the following two (which both lead to the same result, however):
Fix the hole in the head with using the shape of the autosave on the new one
OR: transform the eyes so that they got the similar shape as in the broken one.

I already tried to use blend from shape but it doesn't work with other objects.
Do I have to join them? Don't the both base keys collide then?
I cannot just join and replace the mesh because I already got texture on it and I don't want to redo that over again.

Should I rename one basis shape and try to fix it this way before joining both? Or is there any other way to blend from a different object?

Thanks for any clue about this.

heads

Edit:...

... solid mode textured solid In texture view there is invisibility, too!

I found that there were two little face holes I did not see. The replacement works then, but the mouth texture and some parts of the head (probably more) are deplaced. Is it possible to assign texture(UV) data only for a selected area of verts?

$\endgroup$
  • $\begingroup$ Do have the two meshes the same amount of vertices (in that area) or did you use dyntopo? $\endgroup$ – josh sanfelici Sep 23 '17 at 7:20
  • $\begingroup$ Same amount of verticies, they are just in different positions (head) $\endgroup$ – xDonnervogelx Sep 23 '17 at 11:33
1
$\begingroup$

Copying shape keys doesn't work because they measure a difference of location from a basis, so your mesh should already know which is that basis location.

You can try selecting in edit mode the eye edgeloop, then with Ctrl++ expand the selection a certain amount of times (as needed, but count them), P to separate the selection.

Do the same with the other mesh, then swap and Join (Ctrl+J) the meshes, remove doubles and adjust where necessary.

If this method doesn't work I think you need a little Python script to copy location only, of selected vertices from one object to another.

Consider also the idea of starting from the correct mesh and copying all other vertex data from the textured one (Shift+Ctrl+T for vertices/edges/faces infos; select target, shift select source, Ctrl+L "transfer UV map").

$\endgroup$
  • $\begingroup$ Does this affect(worsen) the textures/material options/UV maps or is it fixed that way? $\endgroup$ – xDonnervogelx Sep 23 '17 at 13:46
  • $\begingroup$ I now did the seperating part, but when I press Ctrl+J the seperated mesh I want to put in disappears. I haven't figured out if it's just invisible but it's gone at first glance $\endgroup$ – xDonnervogelx Sep 23 '17 at 15:11
  • $\begingroup$ When you join two meshes, the first selected becomes part of the second selected, so maybe instead of the eye reach the horse, the horse reached the eye mesh: select the eye first, then the horse, then join. If still disappears check Hide options (Alt H). $\endgroup$ – josh sanfelici Sep 23 '17 at 15:35
  • $\begingroup$ It's there, but only when I activate textured solid and there are no backfaces culled. I tried as you wrote but it leads to an error that does not do what expected. I send the screenshots above. $\endgroup$ – xDonnervogelx Sep 23 '17 at 15:46
  • $\begingroup$ Can you upload your file? $\endgroup$ – josh sanfelici Sep 24 '17 at 0:17
0
$\begingroup$

I now found a way to fix the model.
First, I did as in the first answer.
The UVs were still not applied correctly. I activated an addon that adds more UV texture methods. I tried to transfer the UVs to only the selected area in that way then.

Also, I made sure I applied the UV maps correctly to the textures and I selected the verts of the joined object and moved them from the empty texture layer to the one they belong to.
(Which was not that easy, frankly. I had to open UV editor and 3D view and so deselect everything by 3D View, and then "select similar>image", there were the verts in the image editor, being displayed on an empty image slot. Selected the correct image and it was fixed.)

Then it all worked fine.

Thanks @ josh sanfelici, I wouldn't have found out the first few methods by myself.

Copying shape keys doesn't work because they measure a difference of location from a basis, so your mesh should already know which is that basis location.

You can try selecting in edit mode the eye edgeloop, then with Ctrl++ expand the selection a certain amount of times (as needed, but count them), P to separate the selection.

Do the same with the other mesh, then swap and Join (Ctrl+J) the meshes, remove doubles and adjust where necessary.


This one however, didn't fix my problem, so I searched for a solution on my own:

Consider also the idea of starting from the correct mesh and copying all other vertex data from the textured one (Shift+Ctrl+T for vertices/edges/faces infos; select target, shift select source, Ctrl+L "transfer UV map").

Addons used:
UV:Magic UV
UV:Texture Atlas

(One of them helped me. Not able to say which one, however.)

My issue is now fixed.
Hope this description helps anyone who is facing a similar problem in the future.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.