1
$\begingroup$

I'm modeling a pistol and I've come across this weird problem with shading ( or normals, I don't know what is going on ).

The triangles are showing on flat surface. I search whole internet and haven't found a solution yet....

enter image description here

enter image description here

I know there are ngons ( I used boolean ) but is there any solution other than not using ngons?

$\endgroup$
1
$\begingroup$

Yup, it's the n-gons. One workaround is to select the edges that you want be sharp, hit Ctrl-E, click "Mark Sharp", and then enable "auto-smooth" under the mesh data. Hope that helps!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.