3
$\begingroup$

I appended an object to my scene that already has the animation I want it to have, and I want to rotate it so that it's facing another direction. The problem is that after I rotate it when I go to test out the animation it snaps back into its original position. I was also hoping to scale it. Thanks in advance.

$\endgroup$
3
$\begingroup$

You can do so in Edit Mode. Anything you do in edit mode, rotation, scale remains like that in object mode.

| improve this answer | |
$\endgroup$
  • $\begingroup$ There are lots of gems in blender and pretty easy to use. You just need to look :) Glad it helped. $\endgroup$ – Ali Jibran May 2 '14 at 11:48
  • $\begingroup$ Another way for on top animations is to keyframe a parent object. That way you dont need to mess with the mesh itself. $\endgroup$ – user2859 May 2 '14 at 14:21
1
$\begingroup$
  1. Ensure you are in Object Mode.

  2. Turn on Automatic Keyframe insertion (The red dot shown below): Automatic keyframe insertion image

  3. Select the Armature only. (You may need to adjust the origin of the Armature before rotation)

  4. Rotate! The change will be applied to all keyframes.

| improve this answer | |
$\endgroup$
  • $\begingroup$ This only changes the current keyframe. If the current frame does not have a key, this will add an additional key with the rotation you set. This may or not be the desired outcome. For example, if you wanted to rotate the object while keeping the animated motion intact, this method will not get you there. You should change the object in edit mode, or via a parent. $\endgroup$ – JtheNinja May 27 '18 at 4:16
  • $\begingroup$ For some reason when I tried editing the rotation with the parent or in whole edit mode the animation would rotate but when exporting from blender the animation was not rotated. This was the only way I could fix this? And it did apply to all keyframes (I didn’t expect it to apply to all keyframes) $\endgroup$ – iMacHumphries May 28 '18 at 12:20
0
$\begingroup$

When you model snaps back it could be that you didn't keyframe the location of the root bone or simply single object. When you add keyframes in the default layout all the keyframes are added to a default action e.g. if the name of your object is cube the keyframes will be added to CubeAction.

You could create another Action to take only the additional rotation keyframes and add the current Action and the Rotation-Action to two Stripes in the NLA-Editor. You have several options on how the Actions are blended and where the blending starts.

enter image description here

A more detailed tutorial description

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.