1
$\begingroup$

I am trying to make this figure in 3 quadrant sphere rather than 2 quadrant hemisphere using blender. RGB color internal hemispher to outer hemispher is following [0.56,0.55,0.83],[0,64,0.64,0.87],[0.73,0.73,0.92],[0.85,0.85,,0.98] and outer surface rgb color value is [0.44,0.44,0.5] enter image description here But I am not getting the same rgb value color in blender whatever used in above image. and in blender internal sphere not looking good. Why?

enter image description here

You can see blend file here.

$\endgroup$
  • 1
    $\begingroup$ So basically you want to have same colors as in reference image? What you mean by "not looking good"? $\endgroup$ – cgslav Sep 19 '17 at 18:16
  • $\begingroup$ In Internal sphere there is two horizontal line is visible of different color if you see carefully. $\endgroup$ – user3704712 Sep 19 '17 at 18:18
  • $\begingroup$ Turn off ambient occlusion? $\endgroup$ – Coburn Sep 19 '17 at 18:48
  • 1
    $\begingroup$ It's because the faces of the cutout section are all co-planar so Blender is having a hard time figuring which face to display. $\endgroup$ – bertmoog Sep 19 '17 at 18:53
  • 1
    $\begingroup$ I would look into Z-fighting. $\endgroup$ – SilverWolf Sep 19 '17 at 19:46
3
$\begingroup$

Rounded color values

When you need exact colors, you wouldn't want to use rounded values. To be exact, open your reference in the Image Editor and use the Eyedropper in your RGB node to pick the color. Make sure, your scene doesn't use Filmic log encoding or any viewer LUTs, stay in sRGB the whole time, to maintain color fidelity.

enter image description here

Emission and diffuse combination

As @lucas-leme suggested, the emission shader gives you the exact values from your reference. But your image will look very flat. Create a second renderlayer, don't change any settings, just add a diffuse white material to the material override slot of the second render layer. In the compositor, set up the nodes as shown below, and clamp the diffuse pass down, so it is almost completely white and only contains the core shadows. Multiply this layer over the Emission pass.

enter image description here

please let me know if this helped, or if something is unclear. Here is my blend:

you need to render first, to see the compositing nodes at work.

$\endgroup$
  • $\begingroup$ Hi @yann, Your answer is pretty good. Thank you very much. I need to work out much to understand your reply because I am very much beginner. $\endgroup$ – user3704712 Sep 20 '17 at 19:59
  • $\begingroup$ Okay, this could be an opportunity to make my very first video tutorial, to guide you through the process step by step. I hope this isn't a pressing matter, i'd need a few days until I have time for that :) $\endgroup$ – yann Sep 20 '17 at 21:12
  • $\begingroup$ wow It will be great. But don't waste your time for me. Meanwhile I am also trying to learnt by myself. Hopefully I can do this. $\endgroup$ – user3704712 Sep 21 '17 at 15:34
  • $\begingroup$ Sorry to disturb you. But How you have created the cube object here. What I need to learn to make cube object like you made? Thanks. $\endgroup$ – user3704712 Sep 22 '17 at 20:07
0
$\begingroup$

To get this flat color, without those shadows on the corners, use emission shader. enter image description here

$\endgroup$
  • $\begingroup$ Any comment for rgb color values ? why is it not same? $\endgroup$ – user3704712 Sep 20 '17 at 5:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.