0
$\begingroup$

So, I was playing around with the principaled shader and I noticed that when I included a shadow catcher to my scene, it changed the color/texture of my object. How do I fix it or is it a bug?

Without shadow catcher

With shadow catcher

$\endgroup$
  • 2
    $\begingroup$ Please show an image of your compositing nodes. $\endgroup$ – cegaton Sep 19 '17 at 13:45
  • $\begingroup$ So, I figure the answer. It's because the first picture there is no plane under the head but the one with the shadow catcher has a plane which I guess reflects the light which brighten the head. My nodes setup is simple, it's principled shader to the material output. $\endgroup$ – J.Jesse Sep 19 '17 at 15:22
1
$\begingroup$

So, I figure the answer. It's because the first picture there is no plane under the head but the one with the shadow catcher has a plane which I guess reflects the light which brighten the head. My nodes setup is simple, it's principled shader to the material output.

$\endgroup$
  • $\begingroup$ The shadow catcher plane has a normal material like other planes. You can modify it, but the shadow intensity might change. $\endgroup$ – Cebbi Sep 19 '17 at 20:49
  • $\begingroup$ You confused me, so yes the shadow catcher plane has a normal material because it is just a plane but the shadow catcher setting you can't modify other than the Ray Visibility settings. $\endgroup$ – J.Jesse Sep 20 '17 at 1:26
  • 1
    $\begingroup$ But I found out, if you deselect all the diffuse, glossy, transmission and volume scatter but leave camera and shadow on. The object won't get affected by reflective light. $\endgroup$ – J.Jesse Sep 20 '17 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.