1
$\begingroup$

After updating to 2.79 my 3D manipulators started to behave weirdly. I'm not able to select them, because pivot appears in the clicked position. Only when I turn "Lock to Cursor" off, manipulators seem to work again.

screenshot showing pivot on manipulators

When I start a new project (without even rotating the view), 3D manipulators with "Lock to Cursor" enabled are selectable, but they bevahe oddly, like rotating in wrong direction etc.

Before 2.79 I was able to operate manipulators with "Lock to Curosr" turned on without any trouble. Now I can't work fast because I must switch "Lock to Cursor" again and again just to move around my project.

Can somebody help me, please?

$\endgroup$
1
$\begingroup$

I contacted Blender team and was notified that a fix was found : https://developer.blender.org/T53850

Hope this help =)

| improve this answer | |
$\endgroup$
0
$\begingroup$

I also got similar problems after a while using 2.79 but noticed that in other 3D views in different screen layouts the manipulators worked fine. Solved it by closing the 3D view with the problem completely and opening a new one. Hope this helps.

| improve this answer | |
$\endgroup$
  • $\begingroup$ unfortunately it doesn't work for me :( Thanks for reply. $\endgroup$ – Nathan Alejver Sep 19 '17 at 6:51
0
$\begingroup$

I had the problem until I reset to the factory settings, file > load factory settings. Though, it persists in my save files and I don't know what might be wrong in them yet. I have been able to get a new 3d view to work. Try duplicating the window as well. When this error comes up, I have gotten the manipulator to work if I keep clicking on it but it's not very often.

| improve this answer | |
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.