4
$\begingroup$

So i have a simple bush scene in the blender render engine with a basic lamp and ground plane and i have also switched to material shading mode.

The Bushes

The bushes are basically alpha planes with a leaf texture on it, i duplicated and bunched them up together. The leaf textures was imported into blender using the "Import images as planes" addon so the alpha transparency showed up in the viewport.

The Shadowsenter image description here

As you can see the shadows that are being casted on the groundplane are of the actual geometry and there is no affect of the transparency in it.

The Lamp settings

enter image description here

Here are the lamp settings.

The Material settings of the bush

enter image description here

The Question

The shadows that are being casted on the groundplane are of the actual geometry and not of the alpha, how do i make it cast the shadow of the alpha and not the actual geometry of the alpha planes ?

Edit: My main goal is to produce the shadows in the material view mode and not the rendered view mode because i have to switch to blender game engine later.

$\endgroup$
  • 1
    $\begingroup$ What do your material nodes look like or can you post an image? $\endgroup$ – bertmoog Sep 16 '17 at 22:01
  • $\begingroup$ Lovely plants. That shadow gives them addition effect btw, like freestyle. Screenshot of the material settings related to alpha would be nice $\endgroup$ – Mr Zak Sep 16 '17 at 22:06
  • $\begingroup$ I have edited the question with the material of the bush $\endgroup$ – Retrax Sep 16 '17 at 22:18
4
$\begingroup$

Blender internal can be a bit confusing in that regard. The objects casting the shadows do not determine how those shadows are received in other objects. The receiving objects determine the quality of the shadow.

By default the receiving objects show the shadow of the pane, not of the texture.

enter image description here

The receiving objects (in your case the ground plane) have to be set to receive transparent.

enter image description here

$\endgroup$
  • $\begingroup$ Sorry but this only works in the rendered view mode, i was asking for the shadows to be cast in the "material view mode" which is similar to the blender game engine, which is my main objective, i want the object to cast transparency affect in the material view mode. $\endgroup$ – Retrax Sep 17 '17 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.