4
$\begingroup$

I have a scene with some objects that have image textures. Denoising the entire scene makes the image textures on certain objects to look less sharp.

How do I get Blender to denoise an entire scene excluding certain objects?

I know there's probably a way with Render Layers and the Compositor but I don't know for sure.

$\endgroup$
  • $\begingroup$ I'll mess around with that then. $\endgroup$ – RobotUnderscore Sep 16 '17 at 18:20
  • 1
    $\begingroup$ @RobotUnderscore Can you please elaborate on why you need that? $\endgroup$ – cegaton Sep 16 '17 at 18:32
  • 1
    $\begingroup$ @cegaton My scene includes objects with image textures and I don't want the image textures themselves to be denoised $\endgroup$ – RobotUnderscore Sep 17 '17 at 17:21
7
$\begingroup$

The Denoiser in Blender version 2.79 can be activated per Render Layer, and as such you can mix denoised and noisy footage as you like. If you ever wondered why the Blender Devs have put that Denoiser into the Render Layers context of the Properties Panel, that's why.

All you need to do is separate your scene into Render Layers with the objects in question on them, and using the little checkbox on the Denoiser activate Denoising only for one of them. The same trick can be used if your objects demand different denoise strength settings, of course, and also to render the layers at different sample counts if you wish.

Here's a demo .blend that shows the approach in action:

The first render layer contains all geometry on Layer 1, and has Denoising activated:

enter image description here

The second Render Layer contains only objects on Layer 2 (monkeyhead), Denoiser is turned off for this one:

enter image description here

When you render this using F12, you should get two Render Layers, which then are combined using the correlated Alpha method described in this question here: Where do the white lines come from in my composite?

That trick is really only needed if both render layers mask out each other, which in this case is useful for performance reasons. The result looks like this (floor and cube denoised, monkey noise as usual):

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.