1
$\begingroup$

My video clips which are pulled From OBS, do not line up on blender. I have A/V Sync on. the videos FPS on VLC say it is at 30 fps (plus the raw files DO sync when played back in VLC) and that is what I am trying to render at. Even though the channels do not line up when I render them they come out matching. Now when I try to make the channels line up when editing them and I try to render then the A/V is out of sync in the rendered video.

$\endgroup$
  • $\begingroup$ Possibly Related are you using the VSE? $\endgroup$ – batFINGER Sep 15 '17 at 5:52
  • $\begingroup$ Yes I am, is that not recommended? $\endgroup$ – DeadBaby Sep 15 '17 at 6:11
  • $\begingroup$ The input file is FLV and the Output I am aiming for is MPEG4 $\endgroup$ – DeadBaby Sep 15 '17 at 6:16
  • $\begingroup$ Are you sure this does not happen, with the same identical file, on 2.78 or another previous version? Your question title seems to say that... $\endgroup$ – m.ardito Sep 15 '17 at 6:46
  • $\begingroup$ Correct. I placed some raw files that I had turned into videos in the past with no issues and they do the same thing. I believe before the update i was using 2.78c. $\endgroup$ – DeadBaby Sep 15 '17 at 7:06
2
$\begingroup$

I just edited an OBS file in Blender's VSE and Blender auto-conformed the project frame rate to FPS: 10 FramerateBase: 0.330. So its not quite 30fps. If you added something else to the project first then added the OBS file later, then Blender will default to the first specified frame rate. Either try this rate or add the OBS file first.

Project Custom Frame Rate

Consider checking that you are using SDL as your Audio Device in Blender preferences.

prefs audio device

| improve this answer | |
$\endgroup$
  • $\begingroup$ Yes it changes this for me as well. Have you watched the video back after rendering? My video is about 8 minutes long and at the end the sync is off by about 10 seconds... more or less. I am only using one video file (and the audio that comes with it) $\endgroup$ – DeadBaby Sep 15 '17 at 7:20
  • $\begingroup$ Like i said the video IS at 30 FPS. Maybe this is more of an audio issue instead of a video issue... I am not sure. when i put the rendered video back into blender the sync is good but like i said i put it in as 30 fps because it tries to automaticly move it to the custom 30.3 but the VSE says it is not synced. $\endgroup$ – DeadBaby Sep 15 '17 at 7:45
  • $\begingroup$ Also this new version came from steam... i hope thats not the issue $\endgroup$ – DeadBaby Sep 15 '17 at 7:51
  • $\begingroup$ Hmm, my video is 9 mins 40 secs and it looks rock solid. In fact its a video of a voice against a waveform recorded off a computer screen, so i have a good sync relationship. have you tried changing the Preferences>Audio Device>SDL? $\endgroup$ – 3pointedit Sep 15 '17 at 7:53
  • $\begingroup$ Did you try rendering it out as mkv with h264 codec? $\endgroup$ – 3pointedit Sep 15 '17 at 7:54
0
$\begingroup$

I am not sure what the problem is with OBS FLV files and Blender but I changed my OBS output to mp4 files and the issue is not there with that type. It may have something to do with the FLV files not specifying a Frame rate. When I check the properties > details of the files there is very little information. Blender may just be trying to compensate?

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.