2
$\begingroup$

I realize this sounds dubious ... possibly a bug... probably user error.

When I add a new font to a blender project that came with pre-packaged font it causes the BI animation rendering to crash Blender.

The message in the upper left says, 'Frame 1 ... Raytree Building', then Blender exits with no further warning or error message.

blender render error

... on tinkering around a little more it's a specific true type font that I just imported ...

Any guidance would be appreciated.

$\endgroup$
5
  • $\begingroup$ Does it happen with any font or just specific ones? $\endgroup$ Sep 15, 2017 at 1:01
  • $\begingroup$ A specific font, others are fine. $\endgroup$ Sep 15, 2017 at 8:15
  • $\begingroup$ I got it to work, certain fonts are 'acceptable' in blender ... generally those with ligature, a connection between the letters, will not be supported. I can answer my own question with a citation from blender.org along with a link to fonts that are acceptable. $\endgroup$ Sep 15, 2017 at 20:34
  • $\begingroup$ @StephanLuis I reopened it answer away. $\endgroup$
    – David
    Sep 15, 2017 at 20:58
  • 1
    $\begingroup$ @StephanLuis please write an answer to your own question. Others with a similar problem might find it useful. $\endgroup$
    – user1853
    Sep 16, 2017 at 6:17

1 Answer 1

0
$\begingroup$

Answering My Own Question:

Blender is short on official documentation ... it appears that free type fonts are supported and of those Blender can be picky about fonts with ligatures, or connections between letters.

So far all the fonts from http://www.dafont.com, recommended on that site, that I have tried worked. That said I've only tried 4 that were very close to the original.

With that information I've been able to BI render the animated title sequence.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .