0
$\begingroup$

[![enter image description here][1]][1][One image is of Blender project and the other when imported in Unity][1]

Here are the links to pictures of the problem you can see in the inspectors that theres 1 mesh in Blender and a dozen+ once imported into Unity.

https://imgur.com/E0KRght // Unity

When I import my blender model to unity I cannot assign my model to the player mesh because instead of having 1 mesh my model is divided into a dozen meshes like you can see in the pictures. Of course I have joined all my seperate parts into one final object but unity still decomposes my object. I saved the project as .fbx and I dont know what more specifications to give you here so If you need more Ill answer whatever is needed for you to help me.

Actually maybe I've approched this the wrong way I was trying to replace a prefab with my own model and thought I would just switch mesh reference with the new one.But I think I might have to create a brand new object with its own component. Right now Im not sure if the problem is with my understanding of Blender or my understanding of Unity. Ill remove this post if Ill update if I find a solution. But if you have one for me or can explain what the problem is Im all hears ! Thank You :)!

https://i.stack.imgur.com/L0Gzu.png

AS requested I added a wireframe picture of the model. I had already closed all my modifiers tho

$\endgroup$
1
  • $\begingroup$ Can you show us all the settings you are using when export the model from blender as fbx? $\endgroup$ – Sazerac Sep 15 '17 at 0:28
0
$\begingroup$

Unity needs to split up your meshes when a certain vertex count is reached (65535 vertices). By the huge number of splits you got, I'd guess that you have an extremely high vertex count in your scene. Check if you still have subsuf modifiers on your objects and remove them before you export to unity. Could you show a wireframe?

enter image description here

Edit After seeing your wireframe: it is definetely the vertex count, parts of your mesh are waaay too dense. I dropped in some circles, where the problem is most obvious, but all other parts are too dense as well. Google images for "game topology" to get an ideo how "simple" a mesh should look like, for sufficient performance. All details are usually added via texture and normal-maps. I'd recommend that you use your current model for retology and recreate it with fewer faces. The vast majority of your geometry doesn't conribute to the shape of your model, so you don't need it. Next time, save a version before you aply any modifiers, and in general: be careful with the subsurf. Insteady, add geometry, by hand where it's needed.

$\endgroup$
2
  • $\begingroup$ I edited the post to add a wireframe picture of my model. $\endgroup$ – Frank Charron Sep 15 '17 at 14:25
  • $\begingroup$ Good thing I made 2 saves before applying my modifiers then XD. Could you refer a good video where they cover how to not make those mistakes and also when you say add details with a textures does that mean for exemple: I could make the front of the turbines flat and apply a texture to the front face that would show the inside parts of it as well as the sense of depth?? As well as the small extrusion and insets in the wings and the wires too? $\endgroup$ – Frank Charron Sep 15 '17 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.