1
$\begingroup$

I have a problem with my model. Using mirror modifier or duplicating and scaling -1 on the X axis sometimes results in an half darker than the original one. I have recalculated normals and removed doubles but the problem doesn't get solved. I hope you will be able to help me![enter image description here]1

https://drive.google.com/open?id=0B08odNC5CcQEYkZRdmpYYzRSZWM .blend file

$\endgroup$
  • $\begingroup$ It may be that the edge loop around which to mirror is not perfectly flat and/or not correctly aligned with the object origin. Could you try selecting it and scale to 0 on the mirror axis (looks like X in your case) then snap to cursor Shift+S followed by C, before mirroring. Increasing the Merge Limit of the mirror modifier might also do the trick, but that may also remove vertices that should remain, but are within the limit distance. $\endgroup$ – Duane Dibbley Sep 13 '17 at 20:01
  • $\begingroup$ It doesn't work, unfortunately $\endgroup$ – Growner Sep 13 '17 at 20:44
  • 1
    $\begingroup$ You have 'autosmooth' enabled - and some of the vertices in the nose are sharper than 30 degrees. This is giving that vertical line in his face. Disable auto-smooth or increase the angle. $\endgroup$ – sdfgeoff Sep 13 '17 at 20:50
  • $\begingroup$ I have disabled the autosmooth and even if the transition is lighter in smooth mode it is still very noticeable in flat mode, so it doesn't fix the problem $\endgroup$ – Growner Sep 13 '17 at 20:54
  • 1
    $\begingroup$ If that sharp crease is what's bothering you, it can be remedied by subdividing. 2 subdivisions is enough, and even 1 makes a considerable difference. And about part of the mesh being darker, I believe that this is due to the viewport not being uniformly lit. You can play around with the viewport lighting in the user preferences, under System -> Solid OpenGL lights. $\endgroup$ – Duane Dibbley Sep 13 '17 at 21:02
1
$\begingroup$

if you'r referring to the different left/right shades your model shows above, imho @Duane Dibbley in a comment to your question has the cause and the solution. I'll try to show some details about how to "solve" this issue.

Your model in 3d view is lit by 3 opengl (invisible) lights, which - by default - are not "aligned" with your model, so they cast light and shadows on your model asymmetrically. This is why you get that impression in 3d view.

Your scene has a "real" lamp object, which will light the rendered view, but also is not "aligned" with your model: if you align it on X, and move a bit in front of your model, the rendered view will be perfectly lit in a uniform and symmetric way (even enabling the smooth shading):

enter image description here

To have the same lighting in the (opengl) 3d view, you have to make the (invisible) opengl lights "aligned" with your model, although it could be a bit difficult, but you can try, and you can also switch 2 of them off: open the user preferences panel, go to "system" tab, and try switching off two of them, and then try to make the remaining one "centered" (this is difficult because you can only operate on a small "disc" with the mouse cursor...). Here an example to give you the idea:

enter image description here

$\endgroup$
  • $\begingroup$ Well, it looks like it works. Anyway I don't understand why sometimes this happens and why sometimes it doesn't. Do you know why? $\endgroup$ – Growner Sep 14 '17 at 16:12
0
$\begingroup$

This sure looks like the meshes are simply not fused at some places. If the middle vertices are not in the Merge Limit tolerance of the mirror modifier, they will not be fused and will remain separate, consequently causing different normals and thus shading on either side. So, you could increase the Merge Limit value, but I would rather recommend moving the affected vertices into the middle. This will be easier if you enable Clipping in the mirror modifier. Then you can just drag them towards the middle and they will snap and remain there.

You should keep Clipping enabled to prevent the middle from accidentally leaving the Merge Limit zone during transformations.

$\endgroup$
  • $\begingroup$ Hi, I have enabled clipping and checked the vertices in the middle, I have tried to exaggerate the merging too until I had only a face but it didn't fix the problem. $\endgroup$ – Growner Sep 13 '17 at 20:01
  • $\begingroup$ Can you post a screenshot in Edit Mode, preferably a closeup of the nose region? $\endgroup$ – HENDRIX Sep 13 '17 at 20:08
  • $\begingroup$ imgur.com/a/P6TsB $\endgroup$ – Growner Sep 13 '17 at 20:12
  • $\begingroup$ Ok it should be merged all right. You know you can display the normals, do you? Good for debugging issues like this. In edit mode, in the N info bar, scroll down to Mesh Display and turn on the normals there. $\endgroup$ – HENDRIX Sep 13 '17 at 20:25
  • $\begingroup$ I have already done it, they are fine facing the outside $\endgroup$ – Growner Sep 13 '17 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.