0
$\begingroup$

I've got a bunch of Logitech MX mouses (mice?) which work great for most applications. However for some reason pressing MMB to pan and rotate, causes Blender to zoom in even when I'm not scrolling the wheel. Really annoying.

I'd like to use the RMB or LMB as the rotate / pan selector. So MMB becomes only zoom in / out.

Is this possible? I'm looking through Input but not seeing a remap for MMB -> RMB or LMB.

$\endgroup$
1
  • $\begingroup$ Zoom is Ctrl-MMB - maybe the driver is set to do ctrl click on the MMB? In blenders input settings, change a mouse input and MMB to set the shortcut, does blender show it as MMB or Ctrl MMB? $\endgroup$
    – sambler
    Commented Sep 14, 2017 at 3:40

2 Answers 2

4
$\begingroup$

You're rightly looking in File > User Preferences > Input - it is indeed there, just obscured:

Imgur

Just set Rotate View and Move View as you like.

$\endgroup$
1
  • $\begingroup$ I tried to do that, but right-clicking still opens context menu. What's the quickest way to switch RMB and MMB buttons so that MMB opens context menus (in all kinds of views) and RMB would rotate the view wherever that's possible? (I'm on 2.9) $\endgroup$
    – Henrik
    Commented Sep 16, 2020 at 14:43
1
$\begingroup$

Okay, so 'emulate 3-button mouse' gets me the ability to option-LMB to rotate. That will work. ~

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .