0
$\begingroup$

I have an edge, just 2 connected vertices. One vertex is hooked to one object, and the other to another object. Now, I need to create geometry around that edge, so it becomes a cylinder and is still hooked to those objects, by this one vertex on each side. I thought the Skin modifier does the trick, but it doesn't seem to work as I would expect, or I don't know how to use it properly. How to keep these hooked vertices, and generate the cylinders at the same time?

$\endgroup$
  • $\begingroup$ Convert the edge to a curve (Alt+C )Then you can bevel the curve to become a cylinder. $\endgroup$ – cegaton Sep 13 '17 at 15:28
  • $\begingroup$ In what way does the Skin modifier not work as expected? $\endgroup$ – Rich Sedman Sep 15 '17 at 22:48
1
$\begingroup$

The Skin modifier is exactly what you need here - although by itself it will only produce a 'cuboid' skin as shown :

hooked edge with skin

Here I've simply created an 'edge' (by merging all vertices of a Cube to a single vertex (using Alt-M) and selecting to merge 'At Center') and then extruding E to form a new vertex and a joining edge - all in Edit mode (Tab)). Then in Edit mode I selected each vertex in turn and used Ctrl-H to 'Hook to New Object'. This creates an Empty at each end of the mesh. I then added the Skin modifier.

Moving the empties moves the respective end of the 'edge' along with the surrounding skin. Note that the sequence of the modifiers in the modifier stack (the list of modifiers) show to the right of the above image) is important - the Hook modifiers must be above the Skin modifier as they must take place before the skin is added. Moving them to after the Skin will result in the vertices being moved while leaving the skin behind.

To turn this into a "cylinder" (with rounded ends) you can further add a Subsurf modifier.

hooked skinned subsurfed

For smooth shading you can enable the 'Smooth Shading' option in the Skin modifier.

Again, the order is important and should be Hook, Hook, Skin, Subsurf. Move the empties and the skin will follow.

This is working as expected for me. If your experience is different to this then please update your question and I can try and answer further.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.