0
$\begingroup$

I've been modelling a donut with the bells and whistles and run into an issue where the icing of the donut is invisible both in the render and in the rendered viewport. I have a situation of having the base donut with these random floating sprinkles (as the icing is not there).

Here's my file on blend exchange:

I checked that the camera icon was showing like the rest of the objects, checked the layers, the passes etc.

At one point I found an AttributeError in the console talking about "SpaceInfo" and "tree_type" but sadly I could not reproduce the issue to get it to trigger again. I scoured the web to find a similar issue but no one seemed to have what I do, i checked my modifiers on that object to see whether the subsurf was doing something weird but it wasn't, so I leave this up to you. Thanks in advance.

$\endgroup$
  • 1
    $\begingroup$ "I have attached my file on blend exchange"... but you forgot to paste the provided link in the question text... $\endgroup$ – m.ardito Sep 13 '17 at 10:30
  • 1
    $\begingroup$ edited the question $\endgroup$ – NBoss Sep 13 '17 at 10:31
3
$\begingroup$

You must check the "Emitter" box in the Render panel of your Particle System settings, otherwise the mesh won't show up, only the particles.

enter image description here

$\endgroup$
  • $\begingroup$ Does the AttributeError line in the console get triggered by this setting or was that from something else? $\endgroup$ – NBoss Sep 13 '17 at 10:37
  • $\begingroup$ I don't think this attribute would trigger an error. That must be something else. $\endgroup$ – Nicola Sap Sep 13 '17 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.