0
$\begingroup$

I'm new to 3d modelling and I'm working on a chess set, while working on the bishop I ran into a shading problem when changing from flat to smooth shading.

problem with shading

After reading another post it seems the issue is that the smooth shading doesn't know what to do with the sharp edge so my idea was to bevel the edge so it can be smoothed. But when trying that the geometry got all kinds of messed up so what would another way to solve this issue be? Thanks in advanced.

$\endgroup$
  • 1
    $\begingroup$ blender.stackexchange.com/questions/89792/… - Note, however, that you have multiple ngons in your mesh. $\endgroup$ – bertmoog Sep 10 '17 at 20:17
  • $\begingroup$ Do ngon's cause a problem with shading? If so how would I fix it while keeping the smoothness of the indent? Subdivide the geometry around the indent? As I said I'm a very early beginner in modelling $\endgroup$ – Will Scott Sep 10 '17 at 20:27
  • $\begingroup$ Ngons shouldn't cause any shading problems—they only become a problem when you want to subdivide or deform your mesh. $\endgroup$ – SilverWolf - Reinstate Monica Sep 10 '17 at 20:29
  • $\begingroup$ And @bertmoog, I don't see any ngons to speak of, just tris and quads. $\endgroup$ – SilverWolf - Reinstate Monica Sep 10 '17 at 20:29
  • 1
    $\begingroup$ @seaturtle There are several ngons along the edges of the boolean cut. And they do cause shading problems because they are not planar, i.e. the faces are curved. $\endgroup$ – Duane Dibbley Sep 10 '17 at 21:40
1
$\begingroup$

Try selecting the edges you want to be sharp and then Ctrl+E "Mark Sharp". Then use the Edge Split modifier and disable angle-based splitting.

$\endgroup$
  • $\begingroup$ This basically emulates flat shading, at least when I tested it on a subdivided cube. $\endgroup$ – SilverWolf - Reinstate Monica Sep 10 '17 at 20:42
  • 1
    $\begingroup$ @seaturtle You have to make the mesh smooth-shaded first. Are you sure you didn't select all the edges? $\endgroup$ – Yoshimaster Sep 10 '17 at 20:44
  • $\begingroup$ Oops, didn't read your post all the way. Sorry about that. (: $\endgroup$ – SilverWolf - Reinstate Monica Sep 10 '17 at 20:45
  • $\begingroup$ When you said disable angle-base splitting is that the edge angle tickbox of the edge split modifier? $\endgroup$ – Will Scott Sep 10 '17 at 20:58
  • $\begingroup$ @WillScott Edge angle tickbox $\endgroup$ – Yoshimaster Sep 10 '17 at 21:14
0
$\begingroup$

Don't worry, that's perfectly normal. This is caused by the low number of vertices in your model, and the fact that the viewport only lights it per-vertex. It should look fine in the render.

If it still looks weird in the render, try adding a Subdivision Surface modifier (often called subsurf).

$\endgroup$
  • $\begingroup$ The render still has the shading and the subsurf modifier divided the indent into weird geometry again, I'm going to attempt to redo the indent since it's geometry seems to be the problem. $\endgroup$ – Will Scott Sep 10 '17 at 20:36
  • $\begingroup$ Hm. You could try selecting the edges of the indent and then set Mean Crease to 1 with Shift+E and then 1—this will make subsurf ignore those edges. Your geometry looks just fine! $\endgroup$ – SilverWolf - Reinstate Monica Sep 10 '17 at 20:40
  • $\begingroup$ The subsurf modifier fixes about half the shading but then it creates divots some of the edges? $\endgroup$ – Will Scott Sep 10 '17 at 20:51
  • $\begingroup$ Hm. Which edges does it make the divots on? Do mean creases on those edges fix it? (BTW, another way to mean crease edges is with the Mean Crease box in the transform panel.) $\endgroup$ – SilverWolf - Reinstate Monica Sep 10 '17 at 20:52
  • $\begingroup$ The ones with the deep shading up the side of the indent become divots, I should have taken a picture when I tried it, I'm trying the other answer now. $\endgroup$ – Will Scott Sep 10 '17 at 21:00
0
$\begingroup$

Try Object Data / Normals rollout and enable Auto Smooth with 30⁰ angle (now default value in Blender 2.8).

Setting groups of polys to 'shade smooth' is pretty much useless for low polygon modeling which is why the go-to recommendations for this technique are to 'add more polys'.

Smooth shading basically tries to turn your mesh into a blob of putty, whereas the 30⁰ angle of auto smooth differentiates between angles beyond that limit and renders them differently.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.