1
$\begingroup$

Why my texture is pink as if it were not assigned at all but in texture paint there's the UV texture I'm currently working on?

When exporting my model there is no texture. In the past I used to be able to see the textured model but now it just shows a pink mesh.

I think it could be some issue with the material because I don't see the texture there on the material. Only on the texture tab I see the texture I'm painting in texture paint mode. I'm not sure how to link them back again.

Thanks!

enter image description here

EDIT: adding blend file and removing detail view of texture settings because not enough reputation for more than two links.

$\endgroup$
  • $\begingroup$ It's on Blender render. Changing it to cycles doesn't seem to make any difference. $\endgroup$ – annvnzndrvn Sep 9 '17 at 20:54
  • $\begingroup$ Yes, I'm making sure the image is saved and I also checked the path to make sure that it's found by Blender and the file does exist. I tried creating a new material and now at least the painted texture appears wrapping the preview sphere but the model is still pink as if it couldn't find the texture at all. $\endgroup$ – annvnzndrvn Sep 9 '17 at 21:42
  • $\begingroup$ If the image is saved on the disk then its source has to be Single Image (with the path to the file set up, generally automatically). It used to happen sometimes that it wasn't changed. Try setting image source to Single Image and pointing Blender to the file manually (below the texture datablock, the textbox will appear). $\endgroup$ – Mr Zak Sep 10 '17 at 11:25
  • 1
    $\begingroup$ I just downloaded the blend. The texture is not packed into the blend file so I replaced with a random picture and I don't have your problem. On the gif you added you can see that on the Image menu you have a little '*'. This mean your picture is not saved. Just click on it and save as Image $\endgroup$ – lucblender Sep 12 '17 at 7:13
  • 2
    $\begingroup$ If you have an error while packing it's not a good sign, better save your texture externally, delete it in your blend file, save everything and re-open and reload your texture. $\endgroup$ – lucblender Sep 12 '17 at 7:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.