0
$\begingroup$

I have been trying to model a submarine; I deformed a cylinder and scaled the edges outwards, and the result was a torpedo shape with a front face consisting of six triangular sub-faces. I need to add a circular window on the front face, so I tried converting the triangles to quads using the Remesh modifier. However the end result looks like this:enter image description here The modifier converted the triangles, but now those 4 highlighted vertices project away from the mesh and cause the model to appear crooked instead of tapered on rendering.

Why are these vertices projecting? How do I get them to hug the contours of the mesh?

.blend file here

$\endgroup$
  • 1
    $\begingroup$ Those aren't caused by the Remesh modifier. Since the modifier isn't applied, it doesn't show up in Edit mode. Since your pictures are from Edit mode, my guess would be you accidentally moved the vertices. $\endgroup$ – Scott Milner Sep 9 '17 at 19:02
  • $\begingroup$ Are you sure Remesh modifier isn't responsible for changing the topology, even when they are positioned correctly the mesh is still crooked. I tried again on this model and on another model. The mesh might be perfectly tapered with all vertices aligned correctly, but once the modifier is applied the the mesh becomes crooked, especially if shading is set to smooth. I wish I could add more pictures! $\endgroup$ – K. Ra Sep 9 '17 at 19:43
  • $\begingroup$ Post a blend file. $\endgroup$ – Scott Milner Sep 9 '17 at 19:44
  • $\begingroup$ I uploaded a blend file with Remesh added but not enabled $\endgroup$ – K. Ra Sep 9 '17 at 19:57
0
$\begingroup$

Looking at your .blend file, it appears that your mesh doesn't exactly line up for mirroring. This is partially causing the SubSurf modifier to pinch the mesh. To fix this, select the edge loop on the plane of reflection:

enter image description here

Enable Clipping on the Mirror Modifier:

enter image description here

Scale the edge loop on the X axis by 0 (S , X, 0, Enter). Now, as long as clipping is on, the vertices won't deviate from that midline.

Re-enabling the SubSurf modifier reveals that we don't have any pinching any more:

enter image description here

As far as the topology for your window goes, the Remesh modifier is not the best option for you. It has no regard to symmetry and is best used on complex, triangulated meshes, such as Dyntopo sculpts or 3D capture imports. It would be best to just manually retopologize by merging the tris into an n-gon, then cutting it into quads with the Knife tool (K), like this:

enter image description here

This mesh is still symmetrical and preserves your original mesh, unlike the Remesh result. This will also subdivide nicely:

enter image description here

With more subdivisions and smooth shading:

enter image description here


Download the .blend file here:

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.