0
$\begingroup$

In the 3D view I have a tree behind a house, but despite that the tree is behind the house and way back in the scene, it's just in front of the camera! How come it's like this? I have used a skin modifier to create the tree. Other objects looks like they should depending on their position.

Here is a picture. The leafs on the tree are OK and not visible, just the tree trunk and branches.

enter image description here

$\endgroup$
  • $\begingroup$ can you add a screenshot so we can see this more clearly ? $\endgroup$ – Shams El-Deen Sep 9 '17 at 12:00
  • $\begingroup$ @Shams I added an image $\endgroup$ – 3D-kreativ Sep 9 '17 at 12:05
  • 4
    $\begingroup$ Check that you did not put a check mark beside x-ray in display section for the tree trunk (you will find it in object section in properties panel) $\endgroup$ – Shams El-Deen Sep 9 '17 at 12:18
  • 1
    $\begingroup$ @Shams The x-ray was the problem! Thanks for the help! Question solved. $\endgroup$ – 3D-kreativ Sep 9 '17 at 12:21
  • $\begingroup$ @Shams Why don't you post an answer (maybe include a screen shot so that others who may come across the question can understand easily) and we can knock this out of the unanswered queue. ;-) $\endgroup$ – Mentalist Sep 10 '17 at 7:09
1
$\begingroup$

The Problem is that the x-ray was checked

when the x-ray is disabled the object in back can't be seen like in the photo and when it is enabled it goes front off everything.

For example the back cube (orange) isn't visible clearly because x-ray isn't checked enter image description here

But in this photo it is checked look : enter image description here

this checkbox is used in many things like making/creating/assinging bones without it we could not see the bones: enter image description here

This Checkbox Can be found here : (Properties panel --> Object --> Display)

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.