0
$\begingroup$

This is my first post, just letting you know. I'm often trying to move things in edit mode to exact locations and I find that it either won't let me put it at an exact location like it rounding the value but it's some weird value like 0.000002 when I want it to be 0.0. I can't figure out what's going on with this.

I also had an issue where it would display the location on one of the axis as being 0.0 wich is what i wanted, but it wasn't if I zoomed in and looked closer. When I'd click to change the value it displayed a value something close to 345345-e.32345.

Let me give you an example of the issue. NOTE: it's recreated, not an actual example, but it's quite close to what it's like. It only showed up like that when I clicked on the value otherwise it showed as 0.0. When I tried to set it to 0.0 it didn't take effect. I had to move it to somewhere else and then back to 0.0 before it stopped showing that, but if you zoom in to the object it still isn't centered at 0.0 – it looks like it is until you really zoom in but it will cause issues when I merge it with other geometry that's meant to line up perfectly with it. I also have issues with part of models having parts that don't line up even though I constrained all to cuts extrude and what not too axis. And I end up with tiny holes in my models, and I end up with light leaks.

I've had these issues for years actually. Usually I can fix them but it takes forever and I have better things to do with my time. While I'm at it I'd like to know how to move an object by moving the location of a vert in the transform toolbar like how in the 3d view you can move from active element rather than the median point. I'm pretty sick so I hope I'm making sense.

Here's a WIP model that has the issue described.

enter image description here

I've spent over an hour manually realigning the verts – it's still not done.

Here's a close up on the edges showing what I mean.

enter image description here

$\endgroup$
  • 2
    $\begingroup$ What is your question really? Could you edit your question and shorten it to focus on the point? Precision issues of this kind are expected in all graphics related computer applications at some point, Blender, 3D or otherwise. If you zoom in far enough, or if you move away from scene origin far enough they will become more apparent. $\endgroup$ – Duarte Farrajota Ramos Sep 8 '17 at 12:00
  • $\begingroup$ I could explan bette if thers something you don under stand. $\endgroup$ – Mitchell Mitchells Sep 9 '17 at 6:59
  • 1
    $\begingroup$ This is basically caused by rounding error when you zoom out if I remember correctly, please note that while Blender can be used for approximate CAD solutions, it at the core is a more artistic based application, not a CAD software. If you need something this precise I'd recommend using one of the professional software packages on the market. $\endgroup$ – VRM Sep 11 '17 at 14:58
  • $\begingroup$ im just looking for a workaround for stuff like this Im not using blender for cad work, but I need to merge a bunch of things that are ment to line up. I once came up with a work around for this so I know it can be done, i just don't rember what it is. $\endgroup$ – Mitchell Mitchells Sep 13 '17 at 12:02
4
$\begingroup$

your best option in this case is mesh-align-plus, and modify it according to your needs, I do not understand much of your question but I try to deduce with risk to make a mistake, but this surely fits your problem

Align 1 Align 2 Align 3 Align 4

$\endgroup$
  • 1
    $\begingroup$ It worked very well for me and saved me a lot of time aligning the objects of my models, which are mostly architectural $\endgroup$ – user52476 Feb 16 '18 at 5:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.