0
$\begingroup$

I'm again here that I'm trying to understand how works the water simulation. I've been able to create a realistic water simulation,but probably I haven't understood how I reached the result because I done the same thing for the second time but this time it didn't work. I copied and pasted the objects from the working blender file to another blender project,so objects and settings should be identical,but I haven't obtained the same result. The water does not flow correctly. After 3 days of full work,I resigned,I'm tired and I want to be helped. I attach two blender files,the working one and the not working one.

$\endgroup$
  • $\begingroup$ Please use blend-exchange.giantcowfilms.com for blend files. $\endgroup$ – Ray Mairlot Sep 7 '17 at 18:19
  • $\begingroup$ Very nice bathroom by the way, I hope the answer helps. $\endgroup$ – yann Sep 7 '17 at 20:05
1
$\begingroup$

After looking at your files, I think I found the main problem: In the working.blend, you don't have any units specified in the scene tab. In the not_working.blend you use metric units. If you change that back to none, the water will leave the tap again. Simulations depend heavily on the scale of the environment, so be sure to not touch these settings after successful simulations.

But some things still seem to be off, compared to the working.blend. If you want to be sure, I'd recommend to make the final simulation in the working file. After the simulation is done, select your domain and choose File > Export > Alembic (.abc). Specify the frame-range, check "Selectet Objects only" and click export alembic.
You can now import the resulting .abc file in any other scene. Alembic only exports the fluid mesh itself, you won't have any chance to alter the simulation.

alembic export blender

$\endgroup$
  • $\begingroup$ Your solution worked partially. The water now flows,but not in the exact way as it flows on the working blender file. There is still something that's not good. Check it by yourself ---> drive.google.com/file/d/0B_vrhf_PTNauSndXS2hPVkM1ajA $\endgroup$ – Marietto Sep 7 '17 at 23:02
  • $\begingroup$ Also I have exported the working fluid mesh from the working blender file and I have imported it inside the not working blender file but it didn't work,the water flows in a odd way,maybe there is something thats broken with the washbowl geometry ? $\endgroup$ – Marietto Sep 7 '17 at 23:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.