1
$\begingroup$

I've got something weird. I added a third camera to my scene and all of a sudden, when i press '0' to shift the view to the camera, i get a weird view on my scene, and io am not able to change it (f.e. i cannot zoom or rotate the view when i have 'Lock Camera to view' unchecked). When i do check 'Lock camera to view', and i try to change the position, i get very weird clipping and behavior.

I was using the 2.79 RC2 release. But the problem persists when opening the scene with 2.78.

Position of the camera

Weird clipping

Anyone know what could be the problem? Maybe i pressed some buttom unknowingly?

Thnx anyway, Casper.

$\endgroup$
  • $\begingroup$ What device are you using as render device in Blender? Did you try checking CPU in User prefs? It could be a bug in graphic drivers as it isn't experienced for all users downloading that file. $\endgroup$ – Mr Zak Sep 6 '17 at 13:45
  • $\begingroup$ I was using GPU, i tried setting it to CPU to see if there was any difference, but none whatsoever. Anyway, it's a good tip to always check if a problem persists on CPU, so thnx! $\endgroup$ – Casper Sep 8 '17 at 11:29
1
$\begingroup$

I have a solution, but i still do not know what caused this problem.

When i create an extra Screen Layout (opened the '3D view Full' and pressed the '+' to make it a new one, named it 'Default_2'), and reconstructed my preferred screenview, the problem is gone. The original Default screenview is still broken. Dunno why.

Found this solution in another topic:

Original posted solution to the same problem

$\endgroup$
  • $\begingroup$ check the clip distance for the viewport and the camera read: blender.stackexchange.com/questions/8553/… $\endgroup$ – cegaton Sep 6 '17 at 15:09
  • $\begingroup$ Yes, i tried to edit these values (made them equal to each other) but nothing happened, whatever i did with these settings. $\endgroup$ – Casper Sep 8 '17 at 11:22
0
$\begingroup$

When you enter camera view, does it actually fly into the camera like it's supposed to, or does it fly into some other object?

There's a keyboard shortcut (⌃ CtrlNum 0) that will make the viewport treat another object like a camera. To undo that, select the camera and either press ⌃ CtrlNum 0 or go to View > Cameras > Set Active Object as Camera.

Edit: Apparently this isn't your problem, but I'll leave this answer here in case it helps someone else.

$\endgroup$
  • $\begingroup$ That happens often but it's visible on the first screenshot that in the Properties editor > Scene tab > Scene rollout Camera object is set as active camera. $\endgroup$ – Mr Zak Sep 6 '17 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.