2
$\begingroup$

I am working with a very large scene with a lot of poorly optimized objects (from sketchup.) I am trying to optimize my settings so that I can properly navigate the file to make necessary material changes, etc. I have done the usual things like turning off outline selected, and have achieved fairly good performance. However, there is a big problem.

My current setup is that various objects are broken down into 3 Layers, and each is the child of an empty to help organize them.

Normally, I can fly around the scene just fine without any performance impact. But as soon as I select any object other than the camera, my performance completely tanks! It takes 5-10 seconds to respond to any clicks or commands. This makes it almost impossible to select objects and change their materials, add them to groups, etc.

I am trying to understand why my performance can normally be okay, but then goes to nothing when interacting with objects.

I do not think I can share the specific file as it belongs to a client and cannot be freely distributed (and is 400+mb).

Any ideas what could be going on?

UPDATE: I can add new objects to the scene and select them without any performance impact.

$\endgroup$
  • $\begingroup$ Are you saying the selection action itself takes a long time? If so, try setting File > User Preferences > System > Selection to 'Occlusion Query'. Also, try disabling Double Sided under the Mesh property panel? Some GPUs really don't like that. $\endgroup$ – Mike Pan Sep 6 '17 at 4:33
  • $\begingroup$ @MikePan Already had Occlusion Query on. And no Double Sided in the scene at all. $\endgroup$ – Drudge Sep 6 '17 at 4:48
  • $\begingroup$ Any part of the scene you're not working on at the moment you should either move to another layer, hide, mask, or set the Maximum Draw Type to "Bounds". $\endgroup$ – Mentalist Sep 7 '17 at 12:30
1
$\begingroup$

Blender selection drawing method is notoriously slow. This well known among the devs and a known limitation of the current system.

Basically highlighting the selection outline doubles the required processing power of regular viewport drawing, yielding almost half the FPS.

Unless you plan on rewritting a whole viewport rendering engine code youself, or a new OpenGL realtime renderer there is not much one can do at the moment, as far as I know, other than await the 2.8 release and its modernized real time rendering based on EEVEE engine.

One possible workaround for the time being is turning off selection highlighting in the * 3D View Properties Region > Display > Outline Selected*, though it is not without its downsides. You won't really know what is currently selected or which is the active object while turned off. enter image description here

$\endgroup$
  • 1
    $\begingroup$ I already have it turned off, as stated in the original question. Having it on does not seem to make a huge difference. When I am selecting a new object, the scene performance is fine. When I select anything else, it tanks. $\endgroup$ – Drudge Sep 6 '17 at 4:16
  • $\begingroup$ Ah sorry missed that detail. There is not much more I can say I'm afraid. Try turning off any particles, duplis or other features that add large counts of independent objectd to a scene, those are generally the worst offenders for slow selections $\endgroup$ – Duarte Farrajota Ramos Sep 6 '17 at 4:53
  • 1
    $\begingroup$ I'm afraid I don't have any particles or duplis, just a large amount of unique objects. I wouldn't be confused if it was always slow, but I am befuddled because it is only slow when I have one of the imported objects selected. I can add new objects no problem! Thank you for the answer. $\endgroup$ – Drudge Sep 6 '17 at 5:03
1
$\begingroup$

The problems turns out to be an Addon I had enabled. Specifically, AutoRigPro. Disabling this addon removes all performance issues, regardless of what I select. I do not know why this was causing it, and I have not been able to reproduce the problem in other large complex files, so it may have to do with the interactions of several addons. So this problem may not even really be specific to this addon, but to the interactions of several addons.

I discovered this was the cause by disabling all addons temporarily, as described here: Temporarily disable all addons

UPDATE: I talked to the maker of the Addon and we got it fixed. No more problems.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.