1
$\begingroup$

I just exported an animation from Unity (which was part of the standard assets). Strangely, when imported into Blender, the rig was quite messed up (see picture). This makes it quite difficult to skin the model again, and thus to do any animation. Do you have any idea about why this happened and how could I possibly solve it?

Initially I was thinking that this may be a problem of rotation, but I am not really sure. And even if that's the case, how could I rotate each bone around each local axes when they are grouped together? (that is, without having to select and rotate each single bone one by one). enter image description hereenter image description here

$\endgroup$
  • 1
    $\begingroup$ You might want to check the import settings for the armature. You can find it in the bottom left of the import screen. You could try to enable "Ignore Leaf Bones" and "Automatic Bone Orientation". $\endgroup$ – Ron Deijkers Sep 21 '17 at 20:42
  • $\begingroup$ Hi @RonDeijkers, this worked for me here! thanks $\endgroup$ – Armando Marques Sobrinho Nov 10 '17 at 20:00
0
$\begingroup$

Just Restating the Answer to this question:

You might want to check the import settings for the armature. You can find it in the bottom left of the import screen. You could try to enable "Ignore Leaf Bones" and "Automatic Bone Orientation". – Ron Deijkers Sep 21

Please mark this as the best answer for future searches! (All credit to Ron Deijkers BTW).

$\endgroup$
  • $\begingroup$ After more than 1 year, I am happy to mark this as best answer. Thanky ou Sol Snare! :D $\endgroup$ – Vaaal88 Jan 16 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.