0
$\begingroup$

I was working on a smoke sim in 2.78c and when I tried to render, I got nothing. I noticed my device was set to GPU Rendering (with no GPU in my laptop) so I set it back to CPU. Nothing. I checked User Preferences, and it shows None in Cycles Compute Device. I reloaded the factory settings, but it still gives me nothing for compute devices. I'm pretty sure I still have a CPU...? Anyone know what might be causing this? No Cycles Render Devices available

$\endgroup$
1
$\begingroup$

Compute Device None is a bit misleading here – it just means, that there's no GPU available. The scene will be computed by your CPU. Your invisible smoke is quite another matter and should be handled in a separate question.

$\endgroup$
  • $\begingroup$ It seems misleading, but exactly as I say, NO compute device is available. Not even CPU. Nothing. As such, when I start a render, it finishes in 0.01 seconds. It's not invisible smoke, it's straight up failure to render. $\endgroup$ – Marc Sep 5 '17 at 9:06
  • $\begingroup$ It's hard to help here without having a look upon your file. Consider uploading it. Maybe it's just camera clipping, so blender has nothing to render and thus finishes immediatly. $\endgroup$ – Grimm Sep 5 '17 at 9:11
0
$\begingroup$

With the reference to this BUG report, if you have an AMD card, it looks like it is not supported anymore if your card's architecture version is less than 2.0

If you still want to enable it, on the bug report page is a link to a workaround. I'm not adding the workaround details here as it has some warning and will be better if you read from the original page.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.