8
$\begingroup$

Sorry if this was asked before, I did find similar threads on other websites with a workaround, but it would be great if there was a way to do this without having to go through photoshop.

What I need:

enter image description here https://i.imgur.com/qA6X4FL.png

I'm rendering normal maps for foliage textures. The background in that image is a plane with an Emission material with the color 128, 128, 255, and I would expect it to be that exact color when rendered out.

What I get:

enter image description here

https://i.imgur.com/siGUcG7.png Instead, it renders out as 188, 188, 255, because it gets gamma corrected/converted to sRGB color space.

Workaround that I'm aware of: Rendering to OpenEXR does not convert images to sRGB. That EXR can be taken into Photoshop and exported as .png, since Photoshop has a checkbox to convert to sRGB, which you can turn off. This works and it's how I got the first image, but I need to do this process dozens of times, and it's not convenient. Any tips?

Thanks in advance.

$\endgroup$
9
$\begingroup$

Use the color management controls . Change the Viewfrom sRGB to LinearRaw

enter image description here

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Thanks, this worked! I normally use a daily build from some days ago because I'm using the new Principled shader, and this didn't work on that build, the result seems slightly, but noticably, off in the red channel. Hopped on to 2.78 and it works fine though. $\endgroup$ – Demeter Dzadik Sep 2 '17 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.