1
$\begingroup$

So I've noticed that if I've been playing in Blender Render and I switch to cycles after some mesh objects are created etc. in the the scene that many times NOTHING renders or almost nothing. Why is this? Are you not supposed to switch these back an fourth off and on?

$\endgroup$
  • $\begingroup$ What do you mean with nothing renders? Are some objects completely missing? If only the materials are missing, this is because Cycles uses another material system and can not use the materials from the Blender Internal renderer. You need to create Cycles materials for your objects. $\endgroup$ – maddin45 Apr 27 '14 at 10:14
  • $\begingroup$ Ok that's what I mean so basically you can't use objects from blender in cycles and vice versa right? $\endgroup$ – user2963603 Apr 27 '14 at 20:49
  • $\begingroup$ You can use the objects in both renderers, you just have to give them the correct material. $\endgroup$ – maddin45 Apr 27 '14 at 21:08
  • $\begingroup$ Did these comments answer your question? If not, let us know. :) $\endgroup$ – Thom Blair III Apr 27 '14 at 22:45
  • $\begingroup$ Related: blender.stackexchange.com/q/6446/599 $\endgroup$ – gandalf3 Apr 27 '14 at 22:46
3
$\begingroup$

All matierals in cycles use nodes (even if you set up the material in the Properties panel, it will create nodes in the node editor).

Since BI materials don't use nodes by default, when you switch to cycles from BI there won't be any BI nodes in the node tree, yet nodes will be enabled. This will make the material render as transparent.

You can disable nodes (this will restore the old BI material settings, and it will not delete any nodes) by:

  • Pressing the node icon in the Materials panel:

    enter image description here

  • Disabling the checkbox in Node editor > Header:

    enter image description here


If you want to make a single material which works for both BI and Cycles, see Is there a way to have one material for cycles and the BI

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.