1
$\begingroup$

I'm new to Blender and 3d in general. Downloaded 2.78c 2 days ago. Using ubuntu 14.04. Invoke blender from file browser.

I was following tutorial for noobs when I selected Create->Plane. Now every time I click the left mouse button, I get an instance of Plane. I've tried Create->Cube and Sphere, which work but don't 'cleanse the pallet'; I still get instances of Plane with each left click. I can see them accumulate in the Scene panel, where I also delete them. They seem hard to select directly in the viewer. Sometimes after a while I can't select anything in the viewer. Did I accidentally turn something on/off?

It seems like it started after I set UserPreference for SelectWith Left mouse button. I had problems , so I switched back to Right click.

Also I can't get OperatorCheatSheet to display anything. Bad Configuration?

$\endgroup$
  • $\begingroup$ Mayne you add a shortcut without even known, try Shit+A then Mouse over mesh and look if only is "Plane" (okyou have another problem). Or "Plane Left Click" (have a shortcut), Then you need to go User preferences > input then use the Restore button or use and search for plane and you will be able to change or delete the shortcuts for plane. $\endgroup$ – Strapicarus Sep 2 '17 at 1:48
1
$\begingroup$

Blender uses a user configurable shortcut system. We can easily add a shortcut to many operators by RMB on the button or menu item and choosing Add Shortcut. If you then managed to right click on the shortcut entry dialog you would get the right click as the shortcut.

adding a shortcut

If this is what you did, you will see Right Mouse next to the plane in the add menu ⇧ ShiftA->Mesh.

add menu with shortcut

To remove it should be as simple as quitting blender and starting it again. If however you saved the user settings after adding the shortcut, then you will need to remove it manually or revert to factory settings. Note that adding a keyboard shortcut can be removed by right clicking it again, but a mouse shortcut needs to be removed in the input settings.

remove keyboard shortcut

In User Preferences under the Input tab you will find the shortcut. For adding an object, you will find it by expanding 3D View and Object Mode and scrolling down to the bottom of that list.

shortcut list

Click the X icon to the right of the entry to remove it.

remove shortcut

In your case you could also search for plane to find it, other times searching may be the easiest way to find it, if you can think of the right search words. You can also search by shortcut, but you will find many entries for each key and mouse so it doesn't always help.

searching shortcuts

Be sure to save user settings after removing the shortcut so that it doesn't return next time you use blender.

$\endgroup$
  • $\begingroup$ Thanks, Strapicarus. I strongly suspect this is exactly what happened, however I can't be sure - I saw Reload Factory defaults elsewhere and that cured the problem. But your info is exactly the kind of info I need to avoid bumping elbows with this new (to me) system. $\endgroup$ – TonyOB Sep 3 '17 at 8:57
  • $\begingroup$ Oops, I should have added sambler to thankyou list. Thought I had only 1 answer. Not observant yesterday. Sorry 'bout that. $\endgroup$ – TonyOB Sep 4 '17 at 1:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.