I added tracks and stuff, but then when I tried to solve motion track, there was a error that said:

Some Data Failed to Reconstruct

and it also said to look into the console for details, which I did. This is what the console said:

enter image description here

By my understanding, my video is 372 frames long, and Blender is cutting the footage at 318 for some reason. Here is the image of the scene:

enter image description here

Why? Here are links to my .blend file and also my video. Also the next morning I did a camera solve, but then most of the frames went red.

  • $\begingroup$ Hi! Can you upload your blend file so we can see how your scene is set up, since this problem could be caused by many things. If you need a place to upload to, you can use PasteAll.org -- it's very easy to use: pasteall.org/blend :) $\endgroup$ Commented Apr 27, 2014 at 10:07
  • $\begingroup$ First make sure the frame rate of your project matches that of your footage. Then match the project length with that of the footage. On the Movie Clip Editor footage information tab you can see the number of frames for the video footage. If you upload the footage and the blend file it would be easier to know what's going wrong. $\endgroup$
    – user1853
    Commented Apr 27, 2014 at 16:37
  • $\begingroup$ I'm not sure about blender cutting off the last frames of your clip, but for you high solve error. Put some markers on the table leg and the error will drop. Blender needs markers on more then one plane, or in three dimensions. Similar to the marker on the bricks, but more are needed. $\endgroup$
    – David
    Commented Apr 27, 2014 at 20:16
  • $\begingroup$ @ThomBlair I'll be happy to upload my blend file :D $\endgroup$ Commented Apr 27, 2014 at 22:23
  • $\begingroup$ @cegaton I've tried upping the frame rate to 29 fps (what the video was shot in), it has allowed more frames through but only like 4 $\endgroup$ Commented Apr 27, 2014 at 22:40

1 Answer 1


Blender is failing to reconstruct because it cannot get enough good tracking information to reconstruct the 3D motion for a section of the video, so it reconstructs only a portion of the shot. The frames where it failed are marked in red.

There are many reasons why your shot fails to track properly making the 3D reconstruction impossible.

I'll address a few.

1- A successful track is determined primarily by the quality of the shot.

Blurry, distorted images will be much harder to track than clear, sharp ones with unique features in which to anchor the trackers.

In this case, you're getting "rolling shutter distortion" or "jello effect" from the sensor of the camera on your iphone. The movement of the camera makes the image dance all over the frame giving the trackers false information.

-To correct that you would need hold the camera steadier, or undistort the video using other tools like Virtual dub or warp stabilizer on adobe premiere or afterfx.

In parts of the shot the camera moves way too fast. The image has so much motion blur that the trackers no longer have enough features to follow. -solution: Do not move the camera so fast, so the image stays sharp. enter image description here

The scene itself has very few distinctive features to anchor the trackers on. The cement floor and the wall have almost the same texture, so blender has a hard time finding specific points from frame to frame. The best tracking points in an image are those with unique features and sharp contrast. Not much to track here

-Solution: Find a distinctive features in your scene or add them to make the tracking accurate. You can do that with bright tape or with a color that is not part of the scene (you can also use marbles or colored balls). Those markers you can remove later.

2- The way the camera moves in the original shot determines the kind of camera solving that is required.

The default camera solver in blender presumes some parallax, or change in perspective, like when you walk and objects in the foreground move faster in the frame than those far away.

If the camera is static on the same place (not advancing laterally or going up or down) but just rotating or tilting, then the shot cannot be solved with the regular mode in blender.

-Solution: You have to use "tripod solve" (even if your camera was not on a real tripod). That solution will give you a 3D camera that mimics the original move and the tracking points will be projected form the camera, not necessarily reconstructing the geometry of the original objects. In tripod camera solving it is much harder to accurately estimate distance.

3- Accurate tracking is the only way to get a proper solution.

The error messages and red bars you see are all the frames blender couldn't reconstruct and are listed as the errors on the console. This happens as the result of blender not having enough information to accurately recreate the camera in the 3d environment.

Solution: Refine your trackers, make sure they don't slip or start tracking unwanted parts. Delete trackers with errors (use the clear track forward/back tool). Play with the correlation values when the tracker fails. The goal is to have a solve error as low as possible. If you can get it to be around 0.3 you'll be fine

(But you can save yourself some time by going out and shooting a new video keeping in mind all of the above). good luck!



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .