28
$\begingroup$

I'd like to use a background image for my world, but I'm not sure how to do it. Right now I am using the sun as a lightpoint and it looks like sky and a flat plane (not realistic). I was thinking of just using a mountain background image for the world.

I've done that through textures etc. but I don't see ANYTHING in render even though it shows in worlds? What am I doing wrong?

Also what's a cheap quick fix for cases like mine so it looks like the world isn't JUST blue sky? Thanks guys!

$\endgroup$
  • $\begingroup$ It's hard to say why the image isn't appearing in the render without more information. Could you upload your .blend or add some screenshots of your world/texture settings? Also, are you using BI or cycles? $\endgroup$ – gandalf3 Apr 26 '14 at 21:24
  • $\begingroup$ Make sure, your textured background geometry is within the bounds of your clipping settings (you can find those in the camera tab) $\endgroup$ – yann Feb 6 '18 at 18:09
  • $\begingroup$ Have you UV unwrapped the plane before applying textures to it? $\endgroup$ – Bodan Talev Mar 7 '18 at 5:28
39
$\begingroup$

Setting a World Environment Background Texture in Cycles

You can easily set a very nice background image for your world by creating an Environment Texture for your World.

You can use many different kinds of background images, but one of the best types for creating a beautiful 360° background is an HDRI (High Dynamic Range Image). These types of images are designed to wrap around your world in a spherical shape so no matter where you look in the scene, you still see the background image:

enter image description here

There are many sources for free HDR images -- HDRI Hub is one. You can also see many examples in Google.

Here's how to set one up in your scene in Cycles:

  1. Make sure you are using the Cycles Render engine and make sure you are in perspective view, if not press (Numpad-5),

    enter image description here

  2. Set your World's Surface to an Environment Texture and use an HDR image for the background.

    • Object Properties window > World tab > Surface section > click Use Nodes

    • For Color, click on the options button ( enter image description here ), then select Environment Texture

    • Then click Open and select your HDRI file. Here, I'm using "Street in the woods":

    enter image description here

  3. However, in order to see your background image while working on your scene, you MUST be looking through your Camera (press Numpad 0 to switch to it) and also you have to set the 3D Viewport Shading to Rendered:

    enter image description here

    Now when you render your scene, your background image will be visible wherever you point the camera.

$\endgroup$
  • 7
    $\begingroup$ You can make the background visible in the 3D View tools without rendering, under Display and checking World Background. $\endgroup$ – sixones Nov 13 '15 at 21:09
  • $\begingroup$ If you turn on the World Background, remember that unless you are in perspective view, it still isn't visible. Switch from orthotic to perspective view with Numpad 5. $\endgroup$ – kim holder Apr 19 '18 at 16:45
3
$\begingroup$

There is a further point not mentioned yet. To see the background image, it doesn't matter whether you're looking through the camera. What matters is that you are looking in perspective view, not orthographic. When looking through a camera, this is a property of the camera; otherwise, numpad-5 toggles between perspective and orthographic.

In orthographic view, all the rays with which you view the scene are parallel and all of them hit the background image at the same point. The background is then uniformly the colour of that point, and will vary as you rotate your view.

$\endgroup$

protected by cegaton Mar 7 '18 at 6:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.