I basically know how to import this type of file (file-> import-> X3D Extensible) but when i do this with a wrl file i got from DSI Studio (Program to track brainfibres) the fibres show weird dark triangles. if i open the same file in windows' own 3D Builder app the fibres apper as nice as in DSI Studio (lack of color ignored)

So what do i do wrong? is blender the problem? could you suggest annother program to convert the wrl file to an fbx file? i want to use the 3d model for a game being developed in the unreal engine 4.

I put some images in for clarification. first is blender, second is windows 3d builder.

Hopefully someone can help me. Thanks in advance.



  • $\begingroup$ i was not allowed to post more than 2 links in one post. here is a link to a picture of the original source of the wrl file (DSI Studio) imgur.com/a/ReIcN $\endgroup$ Aug 30 '17 at 13:25
  • $\begingroup$ This is likely a geometry problem with the model itself, like inverted normals, duplicate vertex or internal faces, and not a problem with the import process procedure $\endgroup$ Aug 30 '17 at 14:10
  • $\begingroup$ Try removing split normals, see blender.stackexchange.com/questions/76513/…. Note though that could change the look of the model and probably you might need to split normals again somehow. $\endgroup$
    – Mr Zak
    Aug 30 '17 at 14:21
  • $\begingroup$ @DuarteFarrajotaRamos do you know a way how i clould solve the problems you think the model could have? $\endgroup$ Sep 3 '17 at 17:08
  • $\begingroup$ @MrZak I tried to do what you suggested, but i could not clear the normals data, just add custom normals data. I did it that, nothing changed, then cleared the data, again nothing changed. $\endgroup$ Sep 3 '17 at 17:08

Got it!

I have selected the model in blender, changed to from object to edit mode, then pressed ctrl + n and. after that on the lower left hand side appeared "Make Normals Consistent" with a checkbox "Inside". clicked that, exported as fbx, imported in ue4 and everything looks fine.

Thank you for your help!

enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.