2
$\begingroup$

I am using Fedora 26 PCs and ssh to connect from one PC to the other.

Blender version 2.78c cannot run over a SSH connection, but surprisingly version 2.77a has no problem with that!

When I run blender 2.78c over a SSH connection, the main window briefly opens, but crashes within a second with an error message in the terminal:

X Error of failed request:  BadRequest (invalid request code or no such operation)
Major opcode of failed request:  153 (DRI2)
Minor opcode of failed request:  1 (DRI2Connect)
Serial number of failed request:  11
Current serial number in output stream:  11

Obviously this is an X related issue, but it's strange that version 2.77a works just fine, but 2.78c does not...

Is this a bug or a new "feature" in the newer version?

$\endgroup$
  • $\begingroup$ I can't seem to reproduce. Just downloaded and run blender-2.78c-linux-glibc219-x86_64.tar.bz2 on a remote machine and it's been working for several minutes now (I've displayed windows, added primitives, rendered). Remote machine has X.Org X Server 1.18.4 on Ubuntu 16.04 $\endgroup$ – Nicola Sap Aug 30 '17 at 10:08
  • $\begingroup$ Does forcing CPU usage (by running blender as ./blender-softwaregl) result in the same error? $\endgroup$ – Nicola Sap Aug 30 '17 at 10:26
  • $\begingroup$ Yes, it gives exactly same error! I have tried two 2.78c version: one installed via the Yum/RPM repository, and another one by unpacking the pre-compiled download from the blender website. All these 2.78c version have this error. I have an old 2.77a, which works just fine......?!?! $\endgroup$ – spamrefuse Aug 30 '17 at 15:20
  • $\begingroup$ Could it depend on the video driver used on the local and remote PCs? When blender executable runs on remote, but is displayed on local PC: X Error happens when nouveau driver on remote and i915 driver on local PC. No error when radeon driver on remote and i915 driver on local. Could that be the reason? $\endgroup$ – spamrefuse Aug 30 '17 at 15:38
  • $\begingroup$ I don't know really, but it seems like the problem depends on a specific configuration of local and remote drivers and software. I don't know what could have changed between the two versions of Blender. $\endgroup$ – Nicola Sap Aug 30 '17 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.