I have a scene with some objects. Lamps, modelled stuff and imported 3ds objects.

When i try to rotate the 3d View via middlemouse, the pivotpoint is never inside the selected object. It always sits at the middle of the screen.

Is there a way to force blender to pivot around the selected object ? Pivot Point settings imply that you can easily tell blender where the pivotpoint should sit. But if i use it nothing changes. enter image description here Things i already tried: I reset the origin. I tried all Pivot Point Settings. I applied Rotation and Scale. I looked for already asked questions and answers but none of them helped.

What is it im doing wrong ? Is there a simple solution and im just stupid ?

  • 1
    $\begingroup$ "What is it im doing wrong ?" We have absolutely no clue what you are doing at all, wright or wrong. Please edit your question and provide more details and screenshots of your scene. $\endgroup$ Commented Aug 29, 2017 at 23:35
  • $\begingroup$ edited it and hope its clearer $\endgroup$
    – Mnkymnk
    Commented Aug 30, 2017 at 0:13
  • $\begingroup$ Going on new edit, I think OP wants to align view to object Eg with balloon selected, shift numpad . (period). $\endgroup$
    – batFINGER
    Commented Aug 30, 2017 at 7:20
  • $\begingroup$ Pivot point of the object controls how the object will be rotated / transformed around that point and isn't related to the center of the viewport camera rotation, see blender.stackexchange.com/questions/696/… on how to reset it. $\endgroup$
    – Mr Zak
    Commented Aug 30, 2017 at 13:46

1 Answer 1


Assuming that it is the rotation of the 3D view that always pivots around the center of the screen and you would like it to pivot around the selected objects origin instead, you need to activate the "Rotate Around Selection" setting.

File menu > User Preferences > Interface

Blender User Preferences


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .