3
$\begingroup$

I want to use Blender to generate a dataset of videos. As a basis I want to use ShapeNet.

When importing the .obj file, blender also correctly loads all the materials from the .mtl file. By that I mean that they are listed in the material tab of the properties window. But for some objects the materials are not correctly applied to the surfaces.

Example: The object with the ID 3dw.e480a15c22ee438753388b7ae6bc11aa should look like this:

preview of 3dw.e480a15c22ee438753388b7ae6bc11aa on the shapenet website

However, if I just import the file in blender, the rendering will look something like that:

rendered image

So, the colors of the knobs work, also the textures of the pillows, but the rest of the colors don't.

What seems strange to me is, that I cannot select the different faces and color them myself in blender. Also, if I move the main part of the bed, a frame of lines will remain there. Maybe this has something to do with the problem:

enter image description here

Similar problems occur for many objects. For example 3dw.b1696ffd98c753ccea88a0a7eb1222bb. There, the problem with the frame of lines does not occur and I can color the airplane afterwards, but it somehow does not load the materials when imported.

How can it be, that it works for some objects but for others it doesn't?

$\endgroup$
  • 3
    $\begingroup$ Possible duplicate of .fbx export why there are no materials or textures? $\endgroup$ – Duarte Farrajota Ramos Aug 27 '17 at 12:02
  • 3
    $\begingroup$ I don't think so. I did not export the model but start with an .obj and a .mtl file. The materials are all listed in the materials tab of the properties window, they are just not applied to the faces they ought to be. $\endgroup$ – McLawrence Aug 27 '17 at 12:06
2
$\begingroup$

This problem with the materials in Blender with the ShapeNet objects seems to be a common one. This worked for me (I used ShapeNetSem):

You can convert your .obj models to .gltf format using the obj2gltf package. Be sure that the ShapeNet textures can be found during converting: I had to put all the .jpg texture images inside the same directory as the .obj and corresponding .mtl files (you can see which textures are needed for a model by opening its .mtl file in a text editor). Then import your .gltf models in Blender. They should now load properly.

On top of that, you can also try to turn off Backface Culling and Auto Smooth, in Blender. This wasn't necessary in my case, but I've read it helps for some people.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.