When i add a new object Shift A in object mode or in edit mode the rotation is zeroed out like it should be but the rotation is random like X=78 Y=31 Z=100. It always disturbed me like about 3 months and could not find help on the web.

And it happened when i changed accounts on my laptop and started using blender on another account the preferences were reseted, of course, but when i started adding objects the rotation was always random.

Please help!! If I had not told you detailed please tell me what you don't understand, thanks.

As well when adding windows and stuff with the Archimed Add on the rotation as well is random but on the side where is transform, rotation etc... The rotation is zeroed out but in the 3d port view it is rotated in all directions. Please help me and give me some advice to solve this problem/

Thanks, Anton Pogromskyy

  • 3
    $\begingroup$ Check if in the User Preferences > Editing page > New Objects group Align To option is not set to View. If it is set it to World. The last paragraph from the question isn't quite clear as to what Archimed addon is and when rotation is zeroed out and when not. $\endgroup$
    – Mr Zak
    Aug 25, 2017 at 11:17
  • $\begingroup$ Omg Thanks you SOOOOO much!!! It worked! I had to post this question 3 months ago! Thank you! $\endgroup$
    – AntonPg
    Aug 25, 2017 at 13:02
  • $\begingroup$ @MrZak please write an answer. $\endgroup$
    – user1853
    Aug 25, 2017 at 16:19
  • $\begingroup$ @cegaton you or anyone else are very welcome to go ahead and write one $\endgroup$
    – Mr Zak
    Aug 25, 2017 at 17:42

2 Answers 2


Open User Preferences (Ctrl+Alt+U)

In the Editing page go to the New Objects: Align To: Option.

Change it from View to World.

enter image description here


In blender 2.8 you have to set instead of World/View, you have to select the 3D Cursor option.enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .