0
$\begingroup$

The object on Layer 8 ("Planks") is not rendering, although it is totally visible in Viewport.

If I select all the layers together (the desired outcome), then hit Render, all the layers will render except this one. If I move the object to one of the other layers, it will still not render.

"Camera" is selected in "Ray visibility" of the Object panel.

When I go back and forth between objects to compare the Object panel of the problematic object with the others, I see no difference.

"Duplication" is not enabled in the Object panel.

In the Outliner, all three icons for display in Viewport, Select and Render are selected for the object.

I had the same problem a few months back, which was never really resolved because I couldn't share the file because of size issues (same here).

Here are the Render Layers settings - there doesn't seem to be a difference from one of the layer in the scene to another:

enter image description here

I tried to render with two different versions of Blender and found the same problem.

$\endgroup$
1
$\begingroup$

Maybe you already got it.. the problem is that your backwall has a solidify modifier which is only showing during render..if you dsiable it or move your planks a bit to the front it will work.. hope this helps..

What further confuses about this situation is that the Solidify modifier doesn't show in "Rendered Viewport" mode if the Eye isn't ticked in the modifier settings.

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Thanks! This is also what the problem was in the other question I linked. $\endgroup$ – MicroMachine Aug 24 '17 at 16:35
  • $\begingroup$ Glad i could help :) $\endgroup$ – Tobias Aug 25 '17 at 5:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.