I have a cube object and I'm trying to move the camera in a spiral and then render the video. When seen from the camera view, the cube object seems to wobble a lot along the z axis. I have seen this question here but that option is not showing up in my Blender. I'm attaching my blend file here. I'm not sure if it is happening just to me or is it some problem with the camera path?


2 Answers 2


The problem is that the resolution of the path is too small. This results in the path being made up of a series of straight lines that are much longer than the steps of your animated 'follow path', resulting in the jitter.

You can re-create the curve with a higher resolution or you can edit your existing curve to add resolution by selecting the curve and enter Edit mode (Tab). Select all vertices (A), click 'Subdivide' in the tool shelf (T) - this will divide each section of the curve, although they will still form straight lines. Once you have enough additional points, click Smooth (again, in the toolshelf, just below Subdivide) a few times - this will round off the edges, effectively shaving the corners off the curve and making it smooth again.

The result should be a smoothed curve with higher resolution that should no longer cause the jittering.

subdivide and smooth

Edit : Another way is to change the Spline Type of your curve - you currently have this set to 'Poly' (ie, lines). Changing it to Bezier or NURBS will produce a curved path without having to add additional control points. To achieve this, simply enter Edit mode and select all (as above) and then click Set Spline Type in the tool shelf (it's shown at the top of the above image). Select NURBS and your path should be smooth and track with no jitter.

  • $\begingroup$ Thanks man. It worked. I was trying to achieve the same thing by increasing preview U option under Resolution heading in the right side menu in Object mode. Edit mode was the key! awsome! $\endgroup$
    – Sum-Al
    Commented Aug 22, 2017 at 18:46

Late to the game but i just had this problem and tried to subdivide on the now blender 3.2.2 and it became even more jagged. Im a noob in blender so i guess mye scaling was off and what was supposed to be s smooth bezier became a jagged hell. Found out that you can increase the res on the active spline to max (64), and that solved it!

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .