4
$\begingroup$

I have a cube object and I'm trying to move the camera in a spiral and then render the video. When seen from the camera view, the cube object seems to wobble a lot along the z axis. I have seen this question here but that option is not showing up in my Blender. I'm attaching my blend file here. I'm not sure if it is happening just to me or is it some problem with the camera path?

$\endgroup$
6
$\begingroup$

The problem is that the resolution of the path is too small. This results in the path being made up of a series of straight lines that are much longer than the steps of your animated 'follow path', resulting in the jitter.

You can re-create the curve with a higher resolution or you can edit your existing curve to add resolution by selecting the curve and enter Edit mode (Tab). Select all vertices (A), click 'Subdivide' in the tool shelf (T) - this will divide each section of the curve, although they will still form straight lines. Once you have enough additional points, click Smooth (again, in the toolshelf, just below Subdivide) a few times - this will round off the edges, effectively shaving the corners off the curve and making it smooth again.

The result should be a smoothed curve with higher resolution that should no longer cause the jittering.

subdivide and smooth

Edit : Another way is to change the Spline Type of your curve - you currently have this set to 'Poly' (ie, lines). Changing it to Bezier or NURBS will produce a curved path without having to add additional control points. To achieve this, simply enter Edit mode and select all (as above) and then click Set Spline Type in the tool shelf (it's shown at the top of the above image). Select NURBS and your path should be smooth and track with no jitter.

$\endgroup$
  • $\begingroup$ Thanks man. It worked. I was trying to achieve the same thing by increasing preview U option under Resolution heading in the right side menu in Object mode. Edit mode was the key! awsome! $\endgroup$ – Sum-Al Aug 22 '17 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.