0
$\begingroup$

i get these weird pixels when rendering an image here is an exanple i whipped up.enter image description here

not sure of the cause i'm fairly new

$\endgroup$
3
$\begingroup$

Those are refered to as fireflies - search for "reducing fireflies" for ideas of how to reduce/remove them. They look like the result of Caustics - the light reflected or refracted from (usually curved) surfaces. You can disable Caustics in the Render settings Light Paths panel - disable Reflective Caustics and Refractive Caustics and see if that helps. Alternatively, significantly increase your number of samples - but bear in mind you need a lot of samples to render good quality caustics.

$\endgroup$
2
$\begingroup$

In Cycles Render Blender uses path tracing to determine the color of every pixels. On each pixel it involves random values to bounce and see what is the result. Blender tries this several times based on your number of samples, but if it hits directly to the light what you get is this white pixel. (Or other color depending on your light's color.)

Good way to quickly deal with this without increasing render time is to clamp the value. The value I think it refers to amount of light. If somehow your pixel bounces to the light you can make it "does not count".

enter image description here

However your entire scene will be a bit darker since the correct pixels will got clamped too. Your scene is dark and does not contains any visible light source in the view so I think this solution is perfect.

By the way the seed is that random value I talked about. If you change this you will notice that your white pixels change to other places. In animation, this seed will keep those white pixels at its place even if the camera is moving (unless you turn on the clock button)

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.