9
$\begingroup$

I have lost functionality in the tool shelf. When I click on a selector or something in the bottom part of the tool self that you can hide and unhide, nothing happens. I can see the options but when I click it doesn't work. See screenshot where it says "Add Cylinder".

enter image description here

$\endgroup$
  • 1
    $\begingroup$ A better title might attract someone who knows the answer to this. Perhaps something like "Operator properties greyed out" or "Bottom of toolbar inactive" - assuming I'm understanding the question right myself. It's not an uncommon problem. $\endgroup$ – Greg Zaal Jun 11 '13 at 14:41
  • $\begingroup$ I appreciate the advice and will definitely put it to good use, however not everyone is familiar enough with the proper way to format a question so people will answer it. If we want this site to be a resounding success we are going to need to be a bit more flexible and patient with beginners. After all, we are here learn and BECOME experts. $\endgroup$ – Defor Mations Jun 11 '13 at 17:20
  • 3
    $\begingroup$ So become one . . . :D $\endgroup$ – VRM Jan 7 '15 at 20:46
7
$\begingroup$

It's likely caused by one (or more) of the many add-ons you have enabled. Try launching Blender from a console/command-prompt and see if any errors are being reported. Failing that you can go File>Load Factory Setting and start enabling stuff while checking for breakage.

$\endgroup$
  • $\begingroup$ Ok, what I did was similar to this answer except that I got rid of the startup file in the config directory and then restarted. Low and behold everything was back to normal. Just had to redo my layouts. $\endgroup$ – Defor Mations Jun 11 '13 at 17:13
13
$\begingroup$

Make sure Global Undo is enabled in CtrlAltU > User preferences > Editing > Undo:

enter image description here


That panel is called the redo panel, because when you change a setting on it, blender actually redoes the previous operator with the new settings.
If blender can't undo the previous operator first, running it again will add it's effect on top of the result of the previous operator (which is not the desired effect at all).

So this panel is disabled when undo is not available.

$\endgroup$
1
$\begingroup$

Ok, this happened to me again and I have figured out what the problem is/was.

If you are rendering with Luxrender and have sent a render off to Lux, while it is rendering it will not allow access to the operator panel. I guess I'm a bit thick not to have figured this out before but there it is.

As soon as you stop the render in Blender you have access back again. This won't stopp the render in the Lux gui if you are using that though, so you can still continue the render and work in Blender at the same time.

Hope that helps

$\endgroup$
0
$\begingroup$

This happened to me for whatever reason, enabling Global Undo in the User Preferences > Editing panel made it all good again.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.