1
$\begingroup$

I'm newbie in the Blender, and can't understand why colors are adjusted during output.

Here is mine compositor scheme wrong colors

As you can see, the R channel equals to 0.4 in the Combine RGBA Node, but in output it's 170 of 255, ie 0.666. Why does this happen?

Have to mention, it is purely 170 all over the rendered image, so it's not a compression artifact.

$\endgroup$
3
$\begingroup$

Well, solved ! :)

Thanks to the user @cegaton ! Here is what he wrote to comment 1st answer:

@m.ardito The important information you left out of the picture. What you are showing are the scene referred values in 32bit float:The compositor works with scene referred values: unbound linear data. Data is then processed through a display transform (determined in the Color Management section) and converted to Display referred data (in a scale from 0 to 1) The default transform is to sRGB and is not a linear transform. That is true for images saved in 8 bits or 16 bit. The only format that gets saved bypassing the display transform is OpenEXR

So after i set Properties editor ‣ Scene ‣ Color ‣ Display Device to none, all looks correct. Value 102 of 255 is 0.4.

Thank for the help you both @cegaton and @m.ardito !

enter image description here

$\endgroup$
11
  • $\begingroup$ Btw, that doesn't solve alpha-premultiplication, when each channel is divided by alpha during output, but OpenEXR does $\endgroup$ – Oleg Skripnyak Aug 24 '17 at 8:28
  • 1
    $\begingroup$ By convention, RGB alpha encoded imagery should be associated (aka premultplied) alpha as that is the only real-world analogous alpha format, as well as being the only format that works appropriately for pixel pushers, with a small caveat. Unassociated (aka key or straight alpha) is an unsuitable alpha format for image makers. Learning how and why this is true is a critical step one's ability to craft imagery. $\endgroup$ – troy_s Sep 10 '17 at 2:09
  • $\begingroup$ @troy_s i just encode some info into the RGB channels and don't want the alpha channel affects them, this is an original problem that i was going to solve blender.stackexchange.com/questions/87818/… $\endgroup$ – Oleg Skripnyak Oct 7 '17 at 18:00
  • $\begingroup$ “don't want the alpha channel affects them” isn't how alpha works. Further, as said numerous times elsewhere, "None" is not the method to achieve proper output. The whole thing is a huge godforsaken mess with regards to how colour and light are modeled to interact. Setting to “None” implies you are using a whacked nonlinear reference. $\endgroup$ – troy_s Oct 8 '17 at 2:08
  • $\begingroup$ @troy_s Well, do you know other ways to archive this goal ? $\endgroup$ – Oleg Skripnyak Oct 8 '17 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.