0
$\begingroup$

I am a absolute blender beginner. Today I created my first scene which was exactly what I wanted to achieve, but then I Ctrl+A to re-scale everything and added a particle system an boooom my perfect material didn't work after anymore. I am so desperate right now because I spent hours and hours to recreate what I have done before but it will not appear like before, although it was really "simple" :-) Pleeeease please help me to recreate my scene. This is what it looked like today in the morning (with me in the reflection sorry): Render-Preview of Low Poly ice mountains I made this scene by building simple mountains like in this tutorial.

  • Material of the mountain-plain = green Diffuse BSDF.
  • Right above the camera an Area lamp with size 16.000 and Strength 4000.00
  • World Setting: Volumne Scatter with a light blue color and Density 0.008
  • The moon (UV-Sphere) with an Emission Shader white color and Strength 1.100

For every single mountain I selected the faces, created a material and assigned it. For these materials I used the nodes as seen in this screenshot (this is what I tried to recreate): Nodes used What I am not sure of are the settings of the above black&white ColorRamp I think I used the Fresnel Node instead!? Important was, that in the color ColorRamp I used the same start color as I used for the mountain plain to achieve (so I thought) a smooth transition. It will not work out like before - I get hard color edges, not as much glowing as in the picture from earlier today.. Thanks for any help !!

$\endgroup$
  • $\begingroup$ Maybe apllying your scale f*cked up the settings of your mapping node. Lower the z-translation in the mapping node until the color at the bottom of the mountains resembles your ground again. $\endgroup$ – yann Aug 20 '17 at 19:50
2
$\begingroup$

Better method would be to use Separate XYZ node as a factor between Diffuse/Emission shader.

It basically take Z height of your mesh and assign material based on it.

You can control factor by Color Ramp node.

final

Edit:

First of all, issue is from Mapping Node. You need to switch it to Point, set Scale to 1, 1, 1, and lower Z Location value. This will be our 'starting' position. Also set Color Ramp to default state (black to the left, white to the right):

edit_1

Now if you want to control gradient falloff we will use the simplest (I think) method for it by changing only Scale and Location Z values in Mapping Node.

Scale Z value will control gradient falloff - lower value smoother gradient.

Location Z value will move it up and down.

Look at some of these examples (Location Z and Scale Z noted on pictures):

examples

And going further if you want smooth falloff (top left corner) and hard emission on top of it, you can move white value in Color Ramp node to the left a bit to tweak it.

Blend file:

Here are some of the examples, and little extra fun with Color Ramp node.

$\endgroup$
  • $\begingroup$ thanks - I tried your solution and had to adjust my z location value in Mapping. But same problem: No smooth glowing gradient as in my first approach earlier today. I have a hard edge between the colors. Tried to mess around with ColorRamp sliders, axis, .. I cannot think of what I have to adjust. screenshot result of applied settings $\endgroup$ – ho.s Aug 20 '17 at 21:34
  • $\begingroup$ as I do not want to spend too much time in the beginning and I worried enough, I will go with your version having no glowing gradient like I had exactly in my first result. Thanks for your approach. $\endgroup$ – ho.s Aug 21 '17 at 8:30
  • 1
    $\begingroup$ @ho.s upload your file to: blend-exchange.giantcowfilms.com and I will check out whats wrong. $\endgroup$ – cgslav Aug 21 '17 at 11:41
  • $\begingroup$ thank you very much, cool offer! but now I found out why my AND your approach did not work and I always had too hard edges in my gradients: It was all about the mapping node: I had to set the value for *Scale" on the X axis to 4000 - I do not really understand why, but this made the transitions between the colors very very smooth (maybe you can explain :-)) The Location value for Z had to be increased and I needed -90° set as Rotation value for the y axis .. Thanks again! $\endgroup$ – ho.s Aug 21 '17 at 12:54
  • 1
    $\begingroup$ @ho.s check my edit. I think that now you will now everything needed about this method. Look closely to Color Ramp setups in blend file. $\endgroup$ – cgslav Aug 23 '17 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.