2
$\begingroup$

So when I'm extruding inwards, there comes this weird shadow.

enter image description here

But it's only when in smooth shading, if I put the object to flat shading it looks fine.

enter image description here

There isn't any modifications and I tried the offset edge slide, but it didn't work.

So, what is it and where does it come from, and is there a way around it with smooth shading on?

$\endgroup$
5
$\begingroup$

In smooth shading, the vertex normals are interpolated as shown in this profile view diagram :

enter image description here enter image description here

More details in this video : https://youtu.be/PMgjVJogIbc

Most of the times, we want acute angles or right angles to stay sharp.

To do that, you can either :

  • enable Autosmooth and set the minimum angle for smoothing (above that angle the edges will stay sharp) :

enter image description here

Note that Autosmooth only works when Smooth shading is also enabled for the object.

or :

  • manually select the edges you want to keep sharp in Edit mode and click on Mesh > Edges > Mark Sharp. They will appear in blue (you still need to have Autosmooth enabled but this time you can keep the angle at 180° so only your selected edges are smoothed) :

enter image description here

here's how it looks :

or :

  • add edge loops and bevels at the right places to avoid smoothing artifacts. This usually produces more realistic results, since perfectly sharp angles don't exist in the real world even when the bevel is very tiny. Here I highlighted the results of the beveled edges in pink to show you :

enter image description here

and here's how it looks (the bevel is big here, you can make it smaller) :

enter image description here

compared to no bevel at all and smooth shading on all angles :

enter image description here

$\endgroup$
  • $\begingroup$ Is that the best we can do? $\endgroup$ – Ari Jun 28 '18 at 2:57
  • 1
    $\begingroup$ Not anymore. There is now a bevel shader which is available in the Blender 2.8 daily builds. Watch this video to see how to use it: youtu.be/aiB_mpL2C-g $\endgroup$ – ChameleonScales Jun 28 '18 at 22:02
-1
$\begingroup$

That shadow is caused by lack of geometry. Basically, there is not enough stuff for blender to work with. Try adding edge loops at the areas close to the shadows. As you make stuff, you'll learn more about smooth shading and how it works. For now, I suggest you look for tutorials that explain normals and smoothing so that you can better understand what's happening in your meshes.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.