2
$\begingroup$

Like to preface this by saying i have searched the whole internet to no avail, found several people with this problem (usually several years ago) but never found an answer that helped.

For some reason there is a junk action that can not be deleted.

enter image description here

As you can see, all of my actions are fine and dandy except for Cube.040.action. When I export as FBX into unity, it can often nearly crash Unity because there are all of these junk animations called [Object Name]|Cube.040Action.enter image description here

This action is not visible in the NLA editor, cannot be cleared in the outliner, cannot be deleted in Data-Blocks and cannot be cleared by python unless I'm missing something.

What leads me to believe it is some kind of bug is occasionally it will appear in the NLA editor, but is not deletable as the expand button does nothing when clicked.

Any help would be appreciated and im willing to upload the blend file if that would be helpful.

$\endgroup$
6
$\begingroup$

In the outliner, switch the type of information to display to Blender File. Extend Current File > actions. There you have your Cube-Action – right click it and select delete. See screenshot below.

delete action

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Blender is broken, a couple of days ago I had the same question as OP and solved it with your way, but now it does not work anymore, there is no delete option anymore! $\endgroup$ – Black Nov 24 '17 at 15:41
0
$\begingroup$

In blenders NLA Editor there's this option Edit > Remove Empty Animation Data. Additionally, try Object > Make Local > All and File > External Data > Pack All Into .blend. Maybe this mysterious cube is visible and deleteable then. Does that help?

|improve this answer|||||
$\endgroup$
  • 1
    $\begingroup$ The Remove Empty Animation Data command did get rid of some extra blank nla strips that were annoying me, but the Cube.040Action itself still persists and appears to be associated with many objects. I delete Cube.040 and that changed nothing, I dont think it was even associated with the action. Appreciate it though. $\endgroup$ – user44842 Aug 16 '17 at 14:34
  • $\begingroup$ In this case, try to import your objects into a completely new blend file. If this doesn't help, I'm at a loss, too. :) $\endgroup$ – Grimm Aug 17 '17 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.