5
$\begingroup$

I've got a question. I modelled a character and importet it into Gmod. I had the problem recently, that some face were flipped. Then I searched how to fix it and in Blender, it seems that they are showing to the right direction. But when I'm running the game, the faces on many spots of my character were still invisible when I look direktly from the front...

Here are screenshots of my issue: enter image description here This is the edit mode in blender, and the Faces are showing to the right direction o-o

enter image description here here are they still missing. The characters right eye shows up when I'm turning to the left...

In crowbare, everything seems to be alright too...

so what can I do? did I oversee something there? (btw it's my first character and playermodel I did ^^')

$\endgroup$
  • $\begingroup$ Check if the object has scale applied (object mode > Ctrl+A > Scale). The mesh is shown from the left side while in Blender while from the right side while in the game engine so the area of interest is hidden. Generally the mesh looks quite strange in game engine as a whole $\endgroup$ – Mr Zak Aug 14 '17 at 21:29
  • $\begingroup$ Thanks ^^, Okay, I did the shortcut. I there supposed to be a check mark to Scale? Yeah its kinda strange... when I'm moving my character for example sideways, those holes are wandering too... so the front side you see always looks like this. It's like the faces are pointing to the wrong direction.. it's confusing $\endgroup$ – Arktos Aug 14 '17 at 21:42
  • $\begingroup$ Is the character rigged? If yes, is the scale applied to the armature? $\endgroup$ – Mr Zak Aug 14 '17 at 21:52
  • $\begingroup$ yep it is, I'v tried now a few things... removed the checkmark in Shadings>Backface Culling, in the panal Data>Normals put a checkmark in Double Sides... and also applyed the scale to the model and the armature... but it's still the same :/ $\endgroup$ – Arktos Aug 15 '17 at 10:43
  • $\begingroup$ If you can, upload the file and include link in the question; probably it's something either with export options or engine $\endgroup$ – Mr Zak Aug 15 '17 at 15:38
1
$\begingroup$

Silly question; have you tried flipping the normals, and checking that no overlapping faces are present? Its hard for me to see the normals on the left part of the face, and the right looks fine as of where I can see them.

Other than that check that the Vertices are not being weight pulled by other bones. Check it in zero mode in the left hand tool panes when weight painting.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you for answering ^^ I did remove overlapping faces a while ago and didn't edit it since then. for your other suggestion... I'm sorry, I can't follow what you mean by that... ^^' my english isn't so good and especially computerlanguage from new programms is hard to understand for me.. so what is the zero mode? $\endgroup$ – Arktos Aug 14 '17 at 21:25
  • $\begingroup$ It is a Weight Paint Mode, that easily shows weighted vertices, and extremely blackens inactive weights, and it easier to spot rather than blue. I will attach the image link, funny enough my character also misses some faces when in game but in the animation I think it shows it. blenderartists.org/forum/… $\endgroup$ – Pyratae Aug 17 '17 at 21:40
0
$\begingroup$

Depending on the exporter, make sure you triangulate your mesh first.

edit: To clarify some exporters don't properly deal with quads. Usually there is a triangulate option or you have to do it manually. Im assuming it has to do with how normals are calculated/dealth with.

| improve this answer | |
$\endgroup$
  • $\begingroup$ This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review $\endgroup$ – VRM May 25 '18 at 13:14
  • $\begingroup$ @VRM But it does. Without triangulating first the mesh data might end up badly in the end product. I've seen this happen first hand with obj for example. $\endgroup$ – Sidar May 25 '18 at 14:03
  • $\begingroup$ Rather than recommending deletion you could have just asked me to elaborate. $\endgroup$ – Sidar May 25 '18 at 14:46
-1
$\begingroup$
  1. click on your object
  2. select the material
  3. check if the Transparency section has a check mark next to it. remove the check mark.

In the Properties window, Material tab then you are looking for the Transparency section.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you for answering! I've checked the transparency now but there isn't a check mark there... :/ $\endgroup$ – Arktos Aug 14 '17 at 21:18
  • $\begingroup$ @Arktos for sorry i don not know any other solution i get this problem before and that's how i fixed it $\endgroup$ – shar Aug 14 '17 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.