0
$\begingroup$

I have used a simple mesh and to corner I sculpt to give some rough shape. I added the boolean modifier to the name and applied all the modifiers. Added the texture as material. Remove doubles & Normals. Looks good in object mode. When I press Shift+Z the name looks black.

Object Mode

enter image description here

Rendered Mode

enter image description here

$\endgroup$
  • $\begingroup$ Rendered in blender engine or cycles engine? $\endgroup$ – Elmazz Aug 13 '17 at 15:34
  • $\begingroup$ @Elmazz its cycles engine $\endgroup$ – atek Aug 13 '17 at 15:43
1
$\begingroup$

Ok, here is a simple way:

enter image description here

select the area that has black letters by pressing B and press U to unwrap and select Projection from view

Sorry for the previous answer. Did not test it through enough.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thats Perfect know... $\endgroup$ – atek Aug 13 '17 at 16:41
0
$\begingroup$

Your texture lacks a texture coordinate node. One solution is to select the object in edit mode, press U>Project from view, and then go into the material settings and where it says vector, choose "UV".

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ its not working with the above answer $\endgroup$ – atek Aug 13 '17 at 16:21
  • $\begingroup$ whoops xd i'm so unaware today... $\endgroup$ – Elmazz Aug 13 '17 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.