0
$\begingroup$

I want to create a metro and I want to make windows. I created a cube and used bevel, next I used the Boolean option on my metro and cube. This looks like this:

enter image description here enter image description here

But now I have a problem with geometry, exactly with vertices. How I can fix this? Create a lot of edges? There must be a simpler method.

$\endgroup$
  • $\begingroup$ What is the purpose of this mesh? Do you want it to be high or low poly? As a rule of thumb you should avoid using ngons and tris without specific reason. $\endgroup$ – cgslav Aug 11 '17 at 20:08
  • $\begingroup$ No need to create that many vertices in the corners, that's easily added with modifiers, Bevel or Subsurf (depends on the case). Model low-poly window, like 1 or 2 segments in the corners, smoothing will be done afterwards. $\endgroup$ – Mr Zak Aug 12 '17 at 15:58
1
$\begingroup$

The reason for this is simple—you're using a mesh. Meshes can't use curved lines; all Blender can do is approximate them with a bunch of straight segments.

If you really need it to be truly curved, you can try using Curves instead. Unfortunately, I don't think it's possible to use a curve with the Boolean modifier, however, so getting it to cut out a window would be quite difficult. I'd use a CAD editor (here's a list) if you need that.

If you don't need that, but want to change the number of segments, look in the bottom left corner of the 3D view. There's an options panel where you can tweak whatever action you did last (but if you did something since then, you'll have to undo and re-bevel it). To add more segments, you can also use the Subsurf tool – select the vertices, and hit W and then "Subdivide Smooth".

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.