5
$\begingroup$

The problem:

The past couple of days I have been working on a scene in blender, every now and then for half an hour or so inbetween other activities. While doing so I didn't save the scene, because I mostly save scenes on exit.

Yesterday when I wanted to continue and opened my laptop, I was greeted with a blue screen of dead (error message UNEXPECTED KERNEL MODE TRAP). I do not know if this crash was related to blender. When I restarted my laptop, everything worked fine again.

However, when I tried to open the last auto save, I could not open the file and got the error "missing DNA block".

As far as I could find, the DNA block is a long string of text in a .blend that represents the structure of the data in the .blend file.

The auto save is said to be edited last on the exact moment when I opened my laptop and got the blue screen. It is considerably larger then the old saves. I figured that it might be saved wrongly, so I opened the .blend file in notepad. The file is not empty and still contains data. However, the last 5% of the file seems to be blank space. I had a file a long time ago that was also wrongly saved and then overwritten entirely by NULL data. It might thus be possible that only the last part is not saved properly because my laptop crashed mid-save.

Is it still possible to recover (a part of) this scene? Can a DNA block be generated from the data in the blend file?

What I have already tried:

I have tried to see if there where other files as well. If I tried recover last session it opens the scene without the progress of the past days. There is a .blend1 file in the folder with the original scene, but this one is also outdated.

I have also tried to append the contents of the auto save to a new .blend file, but the auto save is completely empty.

Update I have done Some research, and it seems that the DNA block is indeed located at the end of the file. I think that blender was writing to the file when the crash happened (or even caused the crash) and thus did not write out the DNA block. As far as I can find, that means that even though all the data is still there (I could find the names of all meshes followed by data in the file in notepad) one can not let blender read it.

I do find putting the DNA block at the end a very questionable decision, as this could mean that no matter when blender fails to write data to a file, the entire file becomes useless.

RIP files.

$\endgroup$
  • 2
    $\begingroup$ "because I mostly save scenes on exit" You should always do incremental saves, and do them frequently. Blender has a nice plus button in the save screen so you don't even need to type the number in your filename. You can also press the plus key on your keyboard, which I find to be even faster. Sorry to hear you lost data, but you really should rethink your saving habits. $\endgroup$ – Mentalist Aug 9 '17 at 12:10
  • $\begingroup$ I know, I know. I never really had any problems with it though as I enabled the auto save settings. $\endgroup$ – dragonfly Aug 9 '17 at 12:40
  • $\begingroup$ Sounds interesting $\endgroup$ – dragonfly Aug 9 '17 at 13:20
  • $\begingroup$ Link. blender.stackexchange.com/questions/2410/… might be able to scrape something out of the wreckage... lol. $\endgroup$ – batFINGER Aug 9 '17 at 13:22
  • $\begingroup$ @batFINGER any idea on how I would use this to fix the DNA structure? $\endgroup$ – dragonfly Aug 9 '17 at 14:57
1
$\begingroup$

Further discovery shows that the majority of people who suffer from this error also experienced a forced computer shutdown, whether it's from a blue screen, a voltage drop or something to that extent. My guess is that Blender was trying to write something on the disk while the computer was shut down, which might have caused the files to become corrupt.

Reading this report, i'm afraid there are no other options available for you besides using an older version.

https://developer.blender.org/T50600

$\endgroup$
  • $\begingroup$ "My guess is that Blender was trying to write something on the disk while the computer was shut down, which might have caused the files to become corrupt." That is my guess too. I suppose because of the blank space at the end of the file that blender got stopped while writing the data to the file. I would just find it odd that missing just the end of a file makes the entire file corrupted. If the DNA blocks would be some sort of index, you would expect it to be at the beginning of the file, so that one could at least save the beginning of a corrupted file. $\endgroup$ – dragonfly Aug 9 '17 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.